This forum is no longer active. Please post your questions to our new community site

Forums Alfresco

Alfresco 3.3g on Amazon EC2 - document preview

Subscribe to Alfresco 3.3g on Amazon EC2 - document preview 3 post(s), 2 voice(s)

 
Avatar africanmint 1 post

Hi, I’m not sure whether this should be in the cloud section or the Alfresco section, but here we go

I’ve installed the ami-4cc53025 image on Amazon EC2. Everything sets up fine, but when I upload a document (either .doc or .pdf) I am not able to view the document within the previewer (error message: The preview could not be loaded from the server. )

I have viewed the logs and receive 2 main errors that are related to this

“07:18:48,604 INFO [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of ‘thirdparty’ subsystem, ID: [thirdparty, default] complete
07:18:48,604 INFO [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting ‘OOoDirect’ subsystem, ID: [OOoDirect, default]
07:18:48,620 INFO [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
07:18:49,968 ERROR [org.alfresco.util.exec.RuntimeExecBootstrapBean] Bootstrap command failed:
Execution result:
os: Linux
command: [/program/soffice.bin, -accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager, -env:UserInstallation=file:///opt/bitnami/apps/alfresco/data/oouser, -nologo, -headless, -nofirststartwizard, -nocrashrep, -norestore]
succeeded: false
exit code: 2
out:
err: Cannot run program “/program/soffice.bin”: java.io.IOException: error=2, No such file or directory
07:18:50,099 WARN [org.alfresco.util.OpenOfficeConnectionTester] An initial OpenOffice connection could not be established."

and

Execution result:
os: Linux
command: [/opt/bitnami/common/bin/pdf2swf, -T, 9, /opt/bitnami/apache-tomcat/temp/Alfresco/RuntimeExecutableContentTransformerWorker_source_5273518503599829565.pdf, -o, /opt/bitnami/apache-tomcat/temp/Alfresco/RuntimeExecutableContentTransformerWorker_target_6480523792732627039.swf]
succeeded: false
exit code: 1
out:
err: Cannot run program “/opt/bitnami/common/bin/pdf2swf”: java.io.IOException: error=12, Cannot allocate memory.

The second error is mentioned in the Alfresco wiki as having insufficient memory, however if I run the standard Alfresco 3.2 (beta) AMI, document previews work fine.

Note I have tried running the Bitnami AMI on Micro and small instances with the same result, whereas the (non-Bitnami) standard alfresco AMI’s work fine.

I would very much like to use the Bitnami packages as they are EBS based and up to date – have you any suggestions to get these items to work?

Thanks very much

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

The EBS images did not include OpenOffice but we will include it in the future. You can install it using “apt-get install”. The second error is a RAM problem, try to increase the assigned RAM for the machine.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

New version with OpenOffice enabled released. Enjoy!

Forums Alfresco