This forum is no longer active. Please post your questions to our new community site

Forums Alfresco

Documentation issues

Subscribe to Documentation issues 8 post(s), 4 voice(s)

 
Avatar Kent 2 post(s)

I downloaded the Ubuntu 10.04 Alfresco 3.3g VM. I am following your documentation here –
https://bitnami.com/faq/virtual_machines

This file does not exist on the VM I downloaded: /opt/bitnami/updateip

This command does not change the password of the database: “sudo /opt/bitnami/mysql/bin/mysqladmin -u root bitnami MyPassword1”

bitnami@alfresco:~$ sudo /opt/bitnami/mysql/bin/mysqladmin -u root bitnami MyPassword1
[sudo] password for bitnami:
/opt/bitnami/mysql/bin/mysqladmin.bin: connect to server at ‘localhost’ failed
error: ‘Access denied for user ’root’@’localhost’ (using password: NO)’

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Is the database running? Try the following:

$ cd /opt/bitnami
$ ./ctlscript.sh status

It is necessary to specify the root password (-p option):

$ sudo /opt/bitnami/mysql/bin/mysqladmin -u root -p MyPassword1

We will update the documentation. When the command request a password you have to write the old password: “bitnami”

I hope it helps

 
Avatar Kent 2 post(s)

This is the output status:

bitnami@alfresco:/opt/bitnami$ sudo ./ctlscript.sh status
[sudo] password for bitnami:
tomcat already running
mysql already running

From your documentation: sudo /opt/bitnami/mysql/bin/mysqladmin -u root password

(I don’t know that much about mysql, so am a little lost there) I tried: sudo /opt/bitnami/mysql/bin/mysqladmin -u root bitnami MyNewPassword
/opt/bitnami/mysql/bin/mysqladmin.bin: connect to server at ‘localhost’ failed
error: ‘Access denied for user ’root’@’localhost’ (using password: NO)’

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Please specify the “-p” option too like I wrote in the previous post.

 
Avatar andrewedward... 30 post(s)

bitnami@linux:~$ cd /opt/bitnami
bitnami@linux:/opt/bitnami$ ./ctlscript.sh status
-bash: ./ctlscript.sh: Permission denied
bitnami@linux:/opt/bitnami$ sudo ./ctlscript.sh status
[sudo] password for bitnami:
tomcat already running
mysql already running
bitnami@linux:/opt/bitnami$ sudo /opt/bitnami/mysql/bin/mysqladmin -u root -p bitnami
Enter password:
/opt/bitnami/mysql/bin/mysqladmin.bin: connect to server at ‘localhost’ failed
error: ‘Access denied for user ’root’@’localhost’ (using password: YES)’

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

It is necessary to specify the password without space “-pbitnami” also it is necessary to add a command for mysqldmin tool. I hope it helps.

 
Avatar truthiness 1 post

New potential user here. Just began evaluating the LAMP VM & ran into this problem. So just to be clear, you need to enter “sudo mysqladmin -u root -pbitnami password superSecretPassword” (where superSecretPassword is the password you want to use). If you do not include your password on the command line & enter it at the prompt it will error.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Right, thanks for posting it.

Forums Alfresco