This forum is no longer active. Please post your questions to our new community site

Forums Alfresco

File Preview

Subscribe to File Preview 18 post(s), 2 voice(s)

 
Avatar andrewedward... 30 post(s)

I installed the VM Alfresco stack 3.0 and 3.3 and in both cases I cannot preview files.

Some appear as thumbnails but the full preview fails – unable to get file from server.

The logs complain of a malformed URL amongst other things.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

could you attach the /opt/bitnami/apache-tomcat/logs/catalina.out file?

 
Avatar andrewedward... 30 post(s)

Attached.

 

Attached Files

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Are you using the latest 3.3g-1?

Version 3.3g-1 2010-09-22

  • Fixed apply_amps scripts
  • Use URIEncoding UTF-8 for Tomcat
  • Enable OpenOffice for Ubuntu Virtual Machine and AMI’s

It is necessary to have OpenOffice enabled

 
Avatar andrewedward... 30 post(s)

I have tried both, “I installed the VM Alfresco stack 3.0 and 3.3 and in both cases I cannot preview files.” with the same result the catalina logs I sent where for the 3.0 version.

Attached is the catalina log from the 3.3 VM.

 

Attached Files

 
Avatar andrewedward... 30 post(s)

This raises a very interesting point actually, what is the best way to migrate to the latest version of the VA?

I am increasingly finding that VA’s are easy to deploy but not so easy to maintain. There is a great deal of knowledge to be gained from installing an environment from scratch as all configuration parameters are set by the install. Because the installation of the application stack in the VA is non-standard and as simple as possible some things are difficult to configure later. Support for specific applications in the stack loses its applicability to some extend and questions regarding installation options are invalid because the installation was carried out by a third party.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

The Stack have already configured most of dependencies but you can customize later. The defficult to install a third party dependency is the same if you install the application manually. To upgrade or migrate the virtual appliance you can download the new virtual appliance and reload the database and the repository. We will look into the document preview issue.

 
Avatar andrewedward... 30 post(s)

ETA?

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

We will try to fix in two or three weeks.

 
Avatar andrewedward... 30 post(s)

This is a prime example of what I am talking about; I am trying to automate a back up of my Alfresco deployment. To do this, I am trying to dump the MySQL database to an external USB drive. I need to access MySQL on the Alfresco Bitnami stack to do this. This requires a username and password for MySQL. I get ‘access denied’.

I looked up the problem in the Bitnami readme:

“# Access denied when trying to connect to MySQL.

If you get an Access Denied message while trying to connect to
MySQL, make sure you are using the correct username and password. ’

This is of very little use.

This is the generic readme for Alfresco:

“MySQL admin user is called ‘root’, and its password is the one you set at
installation time.”

I used the Virtual Appliance! I never set the password for MySQL!

Then is says:

“9.4 Alfresco

For any problem related to Alfresco, please visit
http://wiki.alfresco.com/"

There is clearing a problem with the separation of concerns with this concept – why should Bitnami be responsible for an Alfresco or VMware or EC2 or MySQL issue? While this is true, as a consumer, this just means that I have to spend more time searching in more places to find information to resolve problems and, I am not fully armed with the information that I need to find solutions because I did not carry out the installation.

By the time I have found out who is responsible for the image preview function not working in the Bitnami Alfresco stack, I may as well install the whole thing myself. Then there are comprehensive instructions from one source that align with my installation.

This whole thing might be a false economy however prima facie it seem to be a good idea.

 
Avatar andrewedward... 30 post(s)

bitnami@linux:/opt/bitnami$ sudo -s
[sudo] password for bitnami:
root@linux:/opt/bitnami# mysql -u root -p
Enter password:

Used ‘bitnami’ as password.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

I apologize you have a lot of problems with Alfresco Virtual Appliance. You can find more info about default password for Virtual Appliances at our FAQ https://bitnami.com/faq/virtual_machines

 
Avatar andrewedward... 30 post(s)

Possibly in a related issue, alfresco plugin "This file could not be found’. I can browse repositories and sites but get this error when I try to access a file.

 
Avatar andrewedward... 30 post(s)

Find out what Flash version you have running:

http://www.codegeek.net/flash-version.php

Edit webapps/alfresco/WEB-INF/classes/alfresco/thumbnail-service-context.xml to change

org.alfresco.repo.content.transform.swf.SWFTransformationOptions
flashVersion value=10

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Thanks for posting the solution!

 
Avatar andrewedward... 30 post(s)

This does not solve the problem. How is the Bitnami solution finding going?

I have installed 3.4a on the same VM as I have 3.3g Bitnami VA. The same problem exists.

The activities monitor works though.

 
Avatar andrewedward... 30 post(s)

Am I the only one who has this problem?!

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Sorry, maybe you can find more help in the Afresco official forums.

Forums Alfresco