This forum is no longer active. Please post your questions to our new community site

AMI Joomla 1.6 Error

Subscribe to AMI Joomla 1.6 Error 6 post(s), 3 voice(s)

 
Avatar manateeworks 5 post(s)

After installing the AMI for Joomla 1.6 (Joomla 1.6.1-1 (Ubuntu 10.04)) on EC2, and I attempt to upload a template, I receive the following error: The PHP temporary directory is not set

Please advise.

Thanks

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Try to change the following in the /opt/bitnami/php/etc/php.ini file:

;upload_tmp_dir = → upload_tmp_dir = /tmp

 
Avatar manateeworks 5 post(s)

ok… next question… How do I get FTP’d in to the AMI? I have opened the port in my security group, but I still receive “Connection Refused”. Is there anything I need to do in the Joomla Administrator?

Thanks again in advance.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Take a look at http://wiki.bitnami.com/BitNami_Hosting/FAQ#How_to_upload_files_to_the_server_from_Windows_machine.3f You can connect through sFTP or SCP. Check if your favorite FTP client support it.

 
Avatar manateeworks 5 post(s)

Thank you. That was very helpful. I am learning much.

Next question, for phpMyAdmin, I have set the config file to allow me to access the app, however after logging in, it redirects my to 127.0.0.1 (instead of my VM address).

Please advise.

Thanks again.

 
Avatar victoria Administrator 134 post(s)

Hi,

You will need to directly point to right url in the browser. However the solution described in the link below may work better for you:

http://wiki.bitnami.com/cloud/how_to_connect_to….3f