This forum is no longer active. Please post your questions to our new community site

Can't Access PHPMyAdmin

Subscribe to Can't Access PHPMyAdmin 10 post(s), 6 voice(s)

Avatar idan 9 post(s)

I installed the ami-028f7b6b LampStack for Amazon cloud services on a Micro server today to check it. The problem I’ve got is that I can’t access the PHPMyAdmin using the server DNS Url with /phpmyadmin/ or phpmadmin/index.php.

Am I missing something. I open the MySQL and SSH and HTTP/HTTPS port in the Security Groups.

Please guide,

Thanks in advanced.


Avatar Beltrán Rueda Administrator 3,714 post(s)


phpMyAdmin is configured to be accesible fron You can modified that following this FAQ

Avatar idan 9 post(s)

But I just want it to be available publicly from the URL as my other sites. Does the LAMP comes already installed or need to be installed?

Avatar Beltrán Rueda Administrator 3,714 post(s)


Yes, phpMyAdmin is installed and you can enable following the FAQ. Any other application that you install on top of the LAMP Stack will be available publicly by default.

Avatar Rebel SEO 10 post(s)

I looked at that FAQ but it is unclear to my what I am supposed to do since that is for virtual machines and I (like the OP) have one of your stacks installed on AWS EC2. Please give the command to make phpmyadmin accessible from a remote computer.

Avatar carlos Administrator 144 post(s)


Most of the configuration steps are applicable on both virtual machines and ec2 images because the file structure is similar.

By default phpMyAdmin is restricted to localhost. If you want it to be accessible from anywhere you should follow the steps described in “How to enable phpMyAdmin or phpPgAdmin?” in virtual machines FAQ:

  • SSH to the instance
  • Replace the line “Allow from” with “Allow from all” in the file /opt/bitnami/apps/phpmyadmin/conf/phpmyadmin.conf
  • Restart apache:
sudo /opt/bitnami/ restart apache
  • You can access the phpMyAdmin at http://<public_dns>/phpmyadmin

Alternatively, if you want to keep it only accessible from localhost. You should create a SSH tunnel to the port 80 instead. This can be done as follows in Unix systems:

ssh -i <path_to_private_key> -N -L 8888: <public_dns>

or with Putty on Windows using source port 8888 and destination

Once done it will be accessible at http://localhost:8888/phpmyadmin while the tunnel is opened.

I hope it helps

Avatar kumaril 1 post


I have installed Bitnami Wordpress instance on EC2 and have followed every step. I have been trying to setup phpmyadmin where in there are 2 options as per the documentation .….3f

1] By creating a SSH tunnel to connect to the phpMyAdmin or phpPgAdmin web applications from

I ran the following command by using putty and in the root I used
ssh -v -N -L 8080:localhost:80 -i your-key-dir/bitnami_hosting.pem bitnami@ec2-your-machine

I have a folder in bitnami which contains my .pem file. When i run the above command it keeps saying permission denied.

Then I tried the second method.

2] Enabling it by editing the “installdir/apps/phpmyadmin/conf/phpmyadmin.conf” file. My conf file looks like this
Alias /phpmyadmin “/installdir/apps/phpmyadmin/htdocs”

  <Directory "/opt/apps/phpmyadmin/htdocs">
  AuthType Basic
  AuthName phpMyAdmin
  AuthUserFile "/opt/apache2/users"
  Require valid-user
  Order allow,deny
  Allow from all
  Satisfy all
  ErrorDocument 403 "For security reasons, this URL is only accesible using localhost ( as the hostname"

With this I was able to see the phpmyadmin login page when I browsed http://public_dns/phpmyadmin/ Then I used the username administrator password but it got redirects to URL which seems local as it starts with 127.0.01 and it gives an error

“can’t establish a connection to the server at”

Is there any other change I am supposed to make in the conf files besides the “Allow from all”

I would appreciate if you can help me out with this.

Avatar Beltrán Rueda Administrator 3,714 post(s)


This could be a cache issue. Have you restarted the Apache server? Could you try with a different browser or cleaning the cache?

Avatar Alan Trevino 2 post(s)


I’m getting this error too when trying to access phpmyAdmin, a quick shot of what I done is:
Install bitnami-mantis-1.2.5-0-linux-installer, I followed the FAQ to install SSH and allow remote access to phpmyadmin, and then I just login to phpmyAdmin (type credentials to access), after this I get “could not connect to”

What is happening I thing is that phpmyAdmin for some reason is redirecting to that ip address which means that is looking for the local server, so it needs to be reconfigured to redirect to the IP entered on the browser.. Does somebody know how to do this?

Avatar Beltrán Rueda Administrator 3,714 post(s)


The phpMyAdmin link always point to Try to access at http://YOUR_MACHINE_IP/phpmyadmin. Also check that you have done this quick guide