This forum is no longer active. Please post your questions to our new community site

Wordpress network/multisite on AWS micro instance

Subscribe to Wordpress network/multisite on AWS micro instance 13 post(s), 2 voice(s)

Avatar pkra 9 post(s)

I’ve found BitNami only earlier this week and it’s really a great tool!

But I’ve had a weird problem with the Wordpress ami. Since I’m a newbie I’m using BitNami’s cloud service on a micro instance at AWS/ec2.

The initial run was perfect. The server came up beautifully, I configured the network according to Everything worked flawlessly: updating to wp 3.2, installing a couple of themes, plugins, creating 2 sites, making some posts etc.

Being new to BitNami’s cloud service I experimented a little and I ran into a rather big problem.

When I stop and restart the server, the module (at …/wordpress ) would either give a 404 error or not respond with the server’s memory usage is at 99%.

After some testing, I think the network activation is the breaking point. When I create a wordpress network, the server does not survive a reboot or start/stop — all other modifications could be done without breaking at reboot.

Has anybody else encountered this? Is it just not feasible to run a network in a micro instance (and if so why does it only break after a reboot?)

Any help is greatly appreciated.

Avatar Beltrán Rueda Administrator 3,714 post(s)


Wordpress requires to configure the URL in the database. The machine includes an “updateip” tool in /opt/bitnami which gets the Amazon public URL and write in the database. If you has changed your URL and this will not change during a reboot you can move or rename this tool. You can find more info at I hope it helps.

Avatar pkra 9 post(s)

@Beltrán Thanks for your advice.

I’m not sure I understand you correctly. Bitnami’s updateip-tool seems to work correctly, i.e., wp-config.php shows the correct DOMAIN_CURRENT_SITE. I haven’t changed the url manually — I’m just running tests so far.

I really think the problem is caused by wp network/multisite. If I don’t activate network/multisite, everything is fine — stop/starting the instance does not cause any problems.

After network/multisite is activated, the instance still runs fine at first. But after one restart (or start/stop), the instance breaks: When starting the instance everything looks fine (e.g. /applications.html works), but as soon as I try to go to /wordpress, the server just does not respond — and the server’s memory usage goes to 99%.

Maybe somebody could try to reproduce this. Anyway, any ideas are appreciated!

Avatar Beltrán Rueda Administrator 3,714 post(s)


Not sure in this case. We will try to reproduce it.

Avatar pkra 9 post(s)

Update. I have failed to reproduce this so far today. I have restarted the instance after each step (update to wp3.2, creating a network, adding 2 sites, adding MathJax plugin) and yet nothing stopped working. (I also noticed that a working micro instance has 99% memory use so that’s not the problem, I guess)

So that’s good news, but I’m a little bit worried because I don’t understand what caused the problems yesterday. I guess I need to experiment more before I trust BitNami+AWS with a non-test run. (and I guess I need to figure out how the different backup solutions work…)

In any case, thanks for trying to help @Beltrán!

Avatar pkra 9 post(s)

Another update. Now it’s broken again — I only stopped and started the instance (no changes made to the installation) and the server now hangs again when accessing /wordpress.

Oh well, more experimenting needed…

Avatar pkra 9 post(s)

@Beltrán I’m really sorry. It seems you were right from the start. Could it be that the updateip-tool doesn’t always work? Running it manually does not work either.

So I changed the wp-config — and get a database-connection error (as expected). But changing the mysql entry using your link does not work because I don’t know the password. I’m sure it’s somewhere in the forum but I can’t find anything…

Avatar pkra 9 post(s)

Ok, I got the password — it’s the wordpress admin’s password (should’ve remembered that myself…)

But, still running

mysql -u root -p -e “USE bitnami_wordpress; UPDATE wp_options SET option_value=‘http://NEW_IP/wordpress/’ WHERE option_name=‘siteurl’ OR option_name=‘home’;”"

does not get rid of the “Error establishing database connection”.

Any thoughts?

Avatar Beltrán Rueda Administrator 3,714 post(s)


Is the database running? Check it using the following command:

$ sudo /opt/bitnami/ status

Are you running the command from the same machine right?

Avatar pkra 9 post(s)

Beltrán, yes the database is running fine. I’m running out of ideas…

Avatar pkra 9 post(s)

and yes, I’m running these in an ssh session — phpmyadmin does not let me login (after ssh-ing it asks me for a password twice, the first I figured out, the other one I didn’t…).

Avatar pkra 9 post(s)

I solved the problem. It was just my lack of wordpress knowledge, nothing to do with BitNami (which I find excellent news!).

Changing ip’s is much more complicated in the case of a network/multisite — each site has its own database entries. I followed… to clean everything up.

I guess this change in ip’s shouldn’t be a problem once the instances is run through a real domain…

@Beltrán, thanks again for your help!

Avatar Beltrán Rueda Administrator 3,714 post(s)

I’m glad to hear that!