This forum is no longer active. Please post your questions to our new community site

Instalar Auth y MDB2

Subscribe to Instalar Auth y MDB2 8 post(s), 3 voice(s)

 
Avatar millasan 5 post(s)

Hola, he actualizado lapp de la versión 1.1.2 a la 1.1.4 y no consiguo instalar los módulos Auth y MDB2.
En realidad, cuando lo instalo con pear (pear install auth…) no hay ningún problema y al listar los módulos, aparecen como instalados, pero en el directorio …/lib/php/ no aparecen las clases .php ni los directorios correspondientes y cuando ejecuto la aplicación me da un error en el que dice que no encuentra el archivo Auth.php.

Que puede estar pasando ?¿?

Muchas gracias

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

How you are installing them? Are you executed the “pear” command from the use_lampstack console. It is problable that you are installing in your own machine. Try the following:

$ cd
$ ./use_lampstack
$ pear install xxx

Cheeers.

 
Avatar millasan 5 post(s)

Hi, I have tried to use the “use_lampstack” console to install auth and mdb2 and the results are the same: modules installed correctly but nothing is created in /opt/…/lib/php/ directory.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

I have tried to install “auth” and I get this result:

downloading Auth-1.6.1.tgz …
Starting to download Auth-1.6.1.tgz (56,527 bytes)
…………..done: 56,527 bytes
install ok: channel://pear.php.net/Auth-1.6.1

And this is the result if I try to find “auth” related files:

$ find . -name auth*
./apache2/manual/howto/auth.html
./apache2/manual/howto/auth.html.ko.euc-kr
./apache2/manual/howto/auth.html.en
./apache2/manual/howto/auth.html.ja.utf8
./apps/phpmyadmin/htdocs/libraries/auth
./php/lib/php/.registry/auth.reg
./php/lib/php/test/Auth/tests/auth_container_pop3_options.php
./php/lib/php/test/Auth/tests/auth_container_pop3a_options.php
./php/lib/php/test/Auth/tests/auth_container_mdb2_options.php
./php/lib/php/test/Auth/tests/auth_container_file_options.php
./php/lib/php/test/Auth/tests/auth_container_mdb_options.php
./php/lib/php/test/Auth/tests/auth_container_db_options.php

I hope it helps.

 
Avatar millasan 5 post(s)

As you can see, in /php/lib/php/ directory neither exist “Auth.php” and “MDB2.php” files nor “Auth” and “MBD2” directories.
I installed them in 1.1.2 version and these files and directories were created in /php/lib/php/.

The result when I install “auth” and “MDB2” modules in 1.2.0 version is: install ok.
But, if we look for into /php/lib/php/ directory, Auth and MDB2 directories, or Auth.php and MDB2.php files, they don’t exist.

As temporary solution, I have tried to copy this files and directories manually from 1.1.2 version to 1.2.0 version of LAPP and our application works without problem (we can authenticate and we can access to DB)

Thanks

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

It is strange, we will look into this issue. Thanks for reporting it.

Cheers,

Beltran

 
Avatar millasan 5 post(s)

Hola, buscando en foros he encontrado esto:

Hi everybody,
I had the same problem but I just resolved it.
Delete .channels directory and run “pear update-channels”
It worked for me.

Concretamente en: http://www.pear-forum.org/topic2301.html

Por si puede servir de ayuda, lo he probado, se instalan los módulos correctamente y funciona.
Saludos.

 
Avatar mike33 1 post

En realidad, cuando lo instalo con pear (pear install auth…) no hay ningún problema y al listar los módulos, aparecen como instalados, pero en el directorio …/lib/php/ no aparecen las clases .php ni los directorios correspondientes y cuando ejecuto la aplicación me da un error en el que dice que no encuentra el archivo Auth.php.