This forum is no longer active. Please post your questions to our new community site

Problemas con Redmine y Oci8

Subscribe to Problemas con Redmine y Oci8 2 post(s), 2 voice(s)

 
Avatar jhony 38 post(s)

Hola a todos,

Estoy instalando Redmine en un computador con Linux Suse Server 10. Descargué el archivo .bin para la instalación y funcionó perfecto. Ahora necesito instalar Ruby-oci8. Para esto hice lo siguiente:

linux-5zu6:~ # cd /opt/redmine
linux-5zu6:/opt/redmine # sh use_redmine
bash-3.1# gem install ruby-oci8

Aca hay una pequeña espera, que termina con el siguiente error:

Building native extensions. This could take a while…
ERROR: Error installing ruby-oci8:
ERROR: Failed to build gem native extension.

/opt/redmine/ruby/bin/ruby extconf.rb
checking for load library path…
LD_LIBRARY_PATH…
checking /opt/redmine/sqlite/lib… no
checking /opt/redmine/ruby/lib… no
checking /opt/redmine/subversion/lib… no
checking /opt/redmine/mysql/lib… no
checking /opt/redmine/apache2/lib… no
checking /opt/redmine/common/lib… no
checking /opt/redmine/sqlite/lib… no
checking /opt/redmine/ruby/lib… no
checking /opt/redmine/subversion/lib… no
checking /opt/redmine/mysql/lib… no
checking /opt/redmine/apache2/lib… no
checking /opt/redmine/common/lib… no
checking ld.so.conf… no
checking for cc… * extconf.rb failed *
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
-with-opt-dir
—without-opt-dir
—with-opt-include
—without-opt-include=${opt-dir}/include
—with-opt-lib
—without-opt-lib=${opt-dir}/lib
—with-make-prog
—without-make-prog
—srcdir=.
—curdir
—ruby=/opt/redmine/ruby/bin/ruby
—with-instant-client
—without-instant-client
./oraconf.rb:562:in `check_cc’: RuntimeError (RuntimeError)
from ./oraconf.rb:549:in `init’
from ./oraconf.rb:680:in `initialize’
from ./oraconf.rb:345:in `new’
from ./oraconf.rb:345:in `get’
from extconf.rb:18
ng
-
————————————————————————-
Error Message:
C compiler doesn’t work correctly.
Backtrace:
./oraconf.rb:562:in `check_cc’
./oraconf.rb:549:in `init’
./oraconf.rb:680:in `initialize’
./oraconf.rb:345:in `new’
./oraconf.rb:345:in `get’
extconf.rb:18
-————————————————————————
See:

Gem files will remain installed in /opt/redmine/ruby/lib/ruby/gems/1.8/gems/ruby-oci8-2.0.3 for inspection.
Results logged to /opt/redmine/ruby/lib/ruby/gems/1.8/gems/ruby-oci8-2.0.3/ext/oci8/gem_make.out

Parecen haber varios errores, uno sobre la estensión nativa gem, y otro más llamativo sobre el compilador c el cual, supuestamente, no está funcionando correctamente.
Que puede causar éste error???

Gracias de antemano por la ayuda… Saludos.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Movido a https://bitnami.com/forums/forums/redmine/topics…