This forum is no longer active. Please post your questions to our new community site

Help running RTF2XML

Subscribe to Help running RTF2XML 7 post(s), 3 voice(s)

Avatar grittyshaker 2 post(s)


I realise this is somewhat outside the standard usage for this stack but I’m trying to get RTF2XML ( to run. I’ve managed to get it installed with no errors (it went in ‘python/lib/python2.5/site-packages’ in my stack) but when I try to run it I get the following error:

dyld: Library not loaded: /bitnami/djangostack/output/common/lib/libreadline.5.2.dylib
  Referenced from: /Applications/djangostack-1.0.2-0/python/bin/.python.bin
  Reason: image not found
Trace/BPT trap

I know literally nothing about servers so any help would be appreciated. I’m on Mac OS 10.5.6 if that is relevant.


Avatar Beltrán Rueda Administrator 3,714 post(s)


How you are trying to execute the command? It seems that the environment variables are not loaded. Could you try to execute first the “use_djangostack” script and then run the command.

$ cd /Applications/djangostack-(version)
$ ./use_djangostack
$ <run command the>


Avatar grittyshaker 2 post(s)

Thanks for your reply.

I’m doing what you suggest and I still get that error message if I try ‘rtf2xml’ from the command line, however it works if I import the package into a Python script and run it that way instead.

Avatar Anentropic 3 post(s)

Please help, I am trying to install PIP on my Djangostack (OS X)

This is neccessary in order to use the Satchmo ecommerce app.

The install instructions for PIP basically just say do ‘easy_install pip’ but I then get the same error as grittyshaker above.

I downloaded the PIP src and installed it using But then when I try to install Satchmo using PIP I again get the error above!

Please help, I need to get this working urgently. I have executed ‘use_djangostack’ first so it’s not that.

Avatar Beltrán Rueda Administrator 3,714 post(s)

Try the following before running the “easy install pip” command:

$ cd /Applications/djangostack-(version)
$ . scripts/

I hope it helps.

Avatar Anentropic 3 post(s)

thank you, that fixed easy_install and the libreadline errors!

PIP failed to install Satchmo with errors like:
Cloning hg (to revision v0.9) to ./src/satchmo
Error [Errno 2] No such file or directory while executing command hg clone -q /Applications/djangostack-1.0.2-0/src/satchmo
Traceback (most recent call last):
File “/Applications/djangostack-1.0.2-0/python//lib/python2.5/site-packages/”, line 477, in main, args)

Not sure if this is a djangostack problem.

Still, I was able to install Satchmo by manually running through the packages required in the pip script.

Avatar Beltrán Rueda Administrator 3,714 post(s)


Error [Errno 2] No such file or directory while executing command hg clone -q

It seems that you have to install Mercurial (hg) in your machine.