This forum is no longer active. Please post your questions to our new community site

Mix the installation of DjangoStack with the application source code checkout ?

Subscribe to Mix the installation of DjangoStack with the application source code checkout ? 5 post(s), 2 voice(s)

 
Avatar keabard 4 post(s)

Hi,

I would like to know if it is possible to have a single .exe that will install BitNami DjangoStack and then will run a checkout of a SVN repository.

Then, it would be possible to completely install a Django app from scratch on a windows OS.

I also encountered some problems with Windows Server 2008. Even when I put my source code in the good directory, the apache server does not seem to recognize it (still have the Django “It worked!” page).

Plus, the scripts (“Launch DjangoStack” “Start service” etc..) don’t seem to work. Any idea ?

Thanks for your answers,

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Do you mean to create your own Django Stack + your application? You can contact with hello at bitnami dot org if you want to distribute your own Stack.

It is possible that you have to try to start the shortcuts as adminsitrator user to work properly.

 
Avatar keabard 4 post(s)

Hi. My djangostack is up and running on a Windows XP, alright.

But i’ve got another problem. I’ve installed python modules with easy_install like this : {DJANGOSTACK_DIR}/python/Scripts/easy_install.exe python-dateutil

The script seems to work, and when I execute {DJANGOSTACK_DIR}/python/python.exe and try to import dateutil, it works. When I run my django shell, i also successfully import dateutil. However, when I try to access my Django app on my web browser, it returns me this error : ImportError : No module named dateutil

I’ve tried it with 2 others modules (pygooglechart and xlrd), and it does the exact same thing : the modules can be imported in python.exe and in the django shell, but when it comes to running the app in my browser, they are not here anymore.

Any idea ?

Thank you.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Could you try to copy the python libraries folders from python/Lib and python/DLLs to apache/bin folder?

 
Avatar keabard 4 post(s)

Hi,

the only differences i saw between apache2\bin\Lib and python\Lib directories were in the site-packages directory, the DLLs folders are the same. Thus, i copied the 3 .egg files corresponding to each of my packages (pygooglechart-0.3.0-py2.5.egg, xlrd-0.7.1-py2.5-win32.egg, and a python_dateutil-1.5.-py2.5.egg) in the apache2\bin\Lib\site-packages directory and now the 2 site-packages directories look exactly the same.

Then, after restarting Apache, i’ve tried to run my Django app, and I get the same error : can’t import neither dateutil, xlrd nor pygooglechart.

Thanks for your answer, but do you have another idea ? =(

EDIT : Okay, i’ve managed to make it work. I added the modules .egg absolute paths to the PythonPath option of the apache server configuration, and now it works. Work as intended or is there something “smarter” to do ?