This forum is no longer active. Please post your questions to our new community site

Forums DokuWiki

DokuWIki _very_ slow

Subscribe to DokuWIki _very_ slow 5 post(s), 3 voice(s)

 
Avatar uli 2 post(s)

Hi,
first I would like to thank you for your great job making very easy to use install packages. I tried some and like them very much.

Yesterday I installed DokuWiki and while installation everthings works fine. I was able to edit the Wiki-pages and to login. But the behavior in general was a bit strange. After every edit action or page change I had to wait for 10 – 15 seconds. First I thought the Wiki had to initially generate ressources or load pages to the cache (a bit slow, but may be …). But now it must be any serious problem …

I work with a rather new PC-system with Window 7 pro (32 bit). Thanks for any help.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Not sure could be the problem. Maybe you can find more help In the following thread http://forum.dokuwiki.org/thread/4032

 
Avatar uli 2 post(s)

Hi again,

after much trying, web-searching and trying again I found the reason for the problem: there is no trouble with the Wiki, the problem is Apache-based.

Sometimes Apache seems to have problems with Win7 or Vista (or Win7 with Apache, who knows …), when a website on a local computer is addressed as http://[local pc-name]/index.html (standard configuration in Bitnami DokuWiki). This problem appears also sometimes, when I changed the address to “localhost” (but only sometimes). There seems to be problem with name resolution, when Apache runs under Win7.

Now I access to the local Wiki-page as http://127.0.0.1/... and everything works fine.

Thanks for the hint.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Thanks for posting the solution. This will be very helpful for other users.

 
Avatar chris 2 post(s)

Thank you very much, Uli, for this post. I’ve noticed a huge increase in performance by changing “localhost” to “127.0.0.1” when accessing my wiki. I’m running a virtual installation of dokuwiki in VirtualBox with NAT port forwarding on Win 7, so the problem doesn’t seem to be limited to native windows 7 installations of apache.

Forums DokuWiki