This forum is no longer active. Please post your questions to our new community site

Forums DokuWiki

starting on a Mac

Subscribe to starting on a Mac 11 post(s), 4 voice(s)

Avatar Gerben 16 post(s)

I have just read the help info coming with the stack, and on the site, but can’t find the answer to this for a Mac. Each time I start up the computer and try to access the wiki ( I get an error saying no connection can be made with the server. I assume Apache needs to be started up first? But how to do that on a Mac.


Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi Gerben,

To start the Apache server on Mac is similar to start on Linux distributions. You have to start a Terminal an go to DokuWiki installation directory:

$ cd /Applications/dokuwiki-(version)/

And then you can start/stop the server using:

$ ./ start

You will see a message similar to:
Syntax OK
/Applications/dokuwiki-(version)/apache2/scripts/ : httpd started at port 8080

And you can access to dokuwiki at

Avatar Gerben 16 post(s)

Hi Antonio,

Thanks. I am half-way there: changing to the installation directory is no problem. But nothing happens after I use ”$ ./ start”. I get no message…


Avatar Gerben 16 post(s)

Ok, it works now, one ”$” too much apparently… Thanks!

Avatar macweenie 5 post(s)

So I am also getting the error

(Failed to Connect

Firefox can’t establish a connection to the server at

Though the site seems valid, the browser was unable to establish a connection.

  • Could the site be temporarily unavailable? Try again later.
  • Are you unable to browse other sites? Check the computer’s network connection.
  • Is your computer or network protected by a firewall or proxy? Incorrect settings can interfere with Web browsing.)

after rebooting my Mac. So I tried the fix above and it worked fine. However, I remembered a post on the MediaWiki forum that gave directions at link that would create a .plist file to AUTOMATICALLY perform this task at startup. The problem is it doesn’t (at least for me).

My .plist config is

(<?xml version=”1.0” encoding=”UTF-8”?>
<!DOCTYPE plist PUBLIC ”-//Apple//DTD PLIST 1.0//EN” “”>
<plist version="1.0">
<dict> <key>Label</key> <string></string> <key>OnDemand</key> <false /> <key>ProgramArguments</key> <array> <string>/Applications/dokuwiki-2008-05-05-2/</string> <string>start</string> </array> <key>RunAtLoad</key> <true /> <key>UserName</key> <string>root</string>

and it is saved in ~/Library/LaunchDeamons. Am I doing something wrong? Why would it work from the terminal but not from the .plist?

Thanks for any help.

Avatar macweenie 5 post(s)

I guess for now I will just run this applescript at boot : shell script “launchctl load -w /Library/LaunchDaemons/”bq.

Avatar macweenie 5 post(s)

Man, how DO you do the blockquotes?

Avatar Beltrán Rueda Administrator 3,714 post(s)


If you run

sudo launchclt load -w /Library/LaunchDaemons/

What services are running? Is Apache and MySQL running? Could you post the result of this action?

ps aux | grep dokuwiki

(You can put the blockquotes starting with a bq. in a new line.)

Avatar macweenie 5 post(s)

The following came directly from my terminal session:

Last login: Fri Jun 27 08:00:51 on console
You have mail.
DMT000:~ eric$ sudo launchclt load -w /Library/LaunchDaemons/
sudo: launchclt: command not found
DMT000:~ eric$ ps aux | grep dokuwiki
eric 17428 1.6 0.0 75516 488 s000 S+ 2:42PM 0:00.01 grep dokuwiki
eric 7149 0.0 0.5 97720 4768 ?? S 10:43AM 0:00.39 /Applications/dokuwiki-2008-05-05-2/apache2/bin/httpd -f /Applications/dokuwiki-2008-05-05-2/apache2/conf/httpd.conf
eric 7143 0.0 0.4 97720 4684 ?? S 10:43AM 0:00.54 /Applications/dokuwiki-2008-05-05-2/apache2/bin/httpd -f /Applications/dokuwiki-2008-05-05-2/apache2/conf/httpd.conf
eric 7138 0.0 0.5 97720 4992 ?? S 10:43AM 0:01.01 /Applications/dokuwiki-2008-05-05-2/apache2/bin/httpd -f /Applications/dokuwiki-2008-05-05-2/apache2/conf/httpd.conf
eric 217 0.0 0.4 97720 4476 ?? S 8:01AM 0:00.19 /Applications/dokuwiki-2008-05-05-2/apache2/bin/httpd -f /Applications/dokuwiki-2008-05-05-2/apache2/conf/httpd.conf
eric 216 0.0 0.4 97720 4472 ?? S 8:01AM 0:00.34 /Applications/dokuwiki-2008-05-05-2/apache2/bin/httpd -f /Applications/dokuwiki-2008-05-05-2/apache2/conf/httpd.conf
eric 215 0.0 0.4 97720 4452 ?? S 8:01AM 0:00.64 /Applications/dokuwiki-2008-05-05-2/apache2/bin/httpd -f /Applications/dokuwiki-2008-05-05-2/apache2/conf/httpd.conf
eric 214 0.0 0.5 97720 5000 ?? S 8:01AM 0:00.87 /Applications/dokuwiki-2008-05-05-2/apache2/bin/httpd -f /Applications/dokuwiki-2008-05-05-2/apache2/conf/httpd.conf
eric 213 0.0 0.5 97720 5028 ?? S 8:01AM 0:02.00 /Applications/dokuwiki-2008-05-05-2/apache2/bin/httpd -f /Applications/dokuwiki-2008-05-05-2/apache2/conf/httpd.conf
eric 211 0.0 0.5 97720 5308 ?? Ss 8:01AM 0:01.38 /Applications/dokuwiki-2008-05-05-2/apache2/bin/httpd -f /Applications/dokuwiki-2008-05-05-2/apache2/conf/httpd.conf
eric 16680 0.0 0.1 97720 784 ?? S 2:25PM 0:00.00 /Applications/dokuwiki-2008-05-05-2/apache2/bin/httpd -f /Applications/dokuwiki-2008-05-05-2/apache2/conf/httpd.conf
eric 7150 0.0 0.5 97720 4908 ?? S 10:43AM 0:00.70 /Applications/dokuwiki-2008-05-05-2/apache2/bin/httpd -f /Applications/dokuwiki-2008-05-05-2/apache2/conf/httpd.conf
DMT000:~ eric$

Avatar Daniel Lopez Administrator 140 post(s)

I think beltran meant launchctl not launchclt

Avatar macweenie 5 post(s)

Okay, so I put the following in an applescript and saved it as an application:

do shell script “launchctl load -w /Library/LaunchDaemons/”

and set it as a login item in system preferences and NOW DokuWiki comes up fine – but why? Why isn’t the .plist being initialized on it’s own WITHOUT this extra step? I guess I should just be happy it works but I hate stuff that doesn’t make sense.

Forums DokuWiki