This forum is no longer active. Please post your questions to our new community site

Forums Drupal

Drupal 7 Install Problems

Subscribe to Drupal 7 Install Problems 8 post(s), 2 voice(s)

 
Avatar shifters67 4 post(s)

Hi all,

tried installing Drupal 7 both from the full wamp installer and drupal module installer and the standalone wamp+drupal installer.

Each time when i try and start Drupal i get the following error

“PDOException: SQLSTATE28000 1045 Access denied for user ’bitnami’@’localhost’ (using password: YES) in lock_may_be_available() (line 165 of C:\BitNami Drupal Stack\apps\drupal\htdocs\includes\lock.inc).”

The only think i am changing from the defaults in the installers is the install path ‘to c:\Drupal Wamp’ and the mysql port from 3306 to 3307 – my server already has a mysql install on 3306 that i dont want to use.

Platform Windows 7 Ultimate with all patches – this is my own local server for me to try 7 out.

Any ideas?

Tom

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

It is strange, we can not reproduce it. Could you try to restart the servers? Could you check the mysql credentials in your_installdir/apps/drupal/htdocs/sites/default/settings.php? Could you try to login in the WAMP database using these credentials?

 
Avatar shifters67 4 post(s)

Hi,

Did as you requested – logged in using MySQL workbench as user bitnami with no problems.

The DB connection specified looks good i.e. correct port etc – MySQL and APache are running and connect to phpMyAdmin with no problems (as administrator that is). Can see the drupal7 database has been created. Restart the services several times – same error when trying to access drupal.

At a loss!

Tom

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Could you try to specify “127.0.0.1” instead of “localhost” in the database configuration in the settings.php file?

 
Avatar shifters67 4 post(s)

Hi,

did as you suggest, and its still the same error – even says drupal@localhost but have i check 3 times i changed it to 127.0.0.1 as below

$databases = array (
‘default’ =>
array (
‘default’ =>
array (
‘database’ => ‘bitnami_drupal7’,
‘username’ => ‘bitnami’,
‘password’ => ‘password-removed!’,
‘host’ => ‘127.0.0.1’,
‘unix_socket’ => ‘C:\BitNami Drupal Stack/mysql/tmp/mysql.sock’,
‘port’ => ‘3310’,
‘driver’ => ‘mysql’,
‘prefix’ => ’’,
),
),
);

Tom

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

The problem is the “unix_socket” line. Please remove it or download again the new Drupal 7 windows modules that it is fixed.

Cheers, thanks for reporting it.

 
Avatar shifters67 4 post(s)

Hi,

just deleted the offending line and it worked fine.

I did download the r01 release module and it still has the same problem (same offending line) as i reinstalled it all from scratch – in the end just deleted the line! :-)

Thanks for the help

TOm

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Thanks for trying it. We released a new fixed version.

Forums Drupal