This forum is no longer active. Please post your questions to our new community site

Exception while running workbench .bat file

Subscribe to Exception while running workbench .bat file 2 post(s), 2 voice(s)

 
Avatar retail 9 post(s)

Hi,

I want to work with a schema workbench to create the xml schema file which I will later upload in the jasperserver to create an analysis view.I used Jasperserver version 3.5.0 .The jdk version I use is jdk 1.5.0_11.When I tried to run the .bat file of workbench version 3.5.4 I am getting the following exception:

Exception in thread “main” java.lang.UnsupportedClassVersionError: Bad version number
in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$100(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)

I guess this is an incompatibility issue.But where does the problem lie:with my jdk version or the workbench version?Please tell me how to resolve this.Also please tell me which are the compatible versions of jdk/workbench for jasper server versions 2.1 and 3.1 and also where to download those workbenches.

Thanks.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

We have shipped jdk 1.5.0_12 and Jasperserver 3.1 and it runs well. It seems a JasperServer error itself and maybe you can find more help in the official JasperServer forums.

Cheers.