This forum is no longer active. Please post your questions to our new community site

LDAP + jasperserver 3.7.0 mac

Subscribe to LDAP + jasperserver 3.7.0 mac 7 post(s), 2 voice(s)

 
Avatar eos 4 post(s)

Hello all,

I have a problem configuring jasperserver to authentificate on an LDAP (actually open directory, which is basicly openldap). Anytime I try to modify the conf file, I get an SEVERE: Error listenerStart in the log ….
Anyone have a clue on it ?
The applicationContext-security.xml file is at http://pastie.org/1335742

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Sorry, this is Jasperserver configuration question and maybe you can find more help in the Jasper official forums.

 
Avatar eos 4 post(s)

thanks beltran
I posted here bacause the same configuration works with jasperserver linux version (from sourceforge), I guess there is something with the bitnami version …

Best regards,

 
Avatar eos 4 post(s)

It seems that spring-ldap*jar files are not present into bitnami version. I’ve copied cas-client-core-3.1.3.jar, spring-ldap-core-1.3.0.RELEASE.jar, spring-ldap-core-tiger-1.3.0.RELEASE.jar and spring-security-cas-client-2.0.4.jar from linux jasperserver sourceforge release but it doens’t work

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Thanks for the info. If you are running the OS X version check that the Java installed on the machine is compatible with the spring-ldap jar files.

 
Avatar eos 4 post(s)

I’m running the OX X version. How can I check that the MacOx X java is compatiblewith spring-ldap.jar files ? I’m unfortunetly no java expert at all :(

>>If you are running the OS X version check that the Java installed on the machine is compatible with the spring-ldap jar files.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

“Spring LDAP requires J2SE 1.4 or higher to run, and works with Spring Framework 2.0.x, 2.5.x as well as 3.0.x”

I think that your Java installed version is higher than 1.4. Try to download the version with dependencies from here http://www.springsource.com/download/community