This forum is no longer active. Please post your questions to our new community site

Forums Joomla!

How to get the URL correct on an Amazon EC2 install (URL)?

Subscribe to How to get the URL correct on an Amazon EC2 install (URL)? 9 post(s), 2 voice(s)

 
Avatar houldsworth1 14 post(s)

I have installed Joomla on an Amazon EC2 instance (using your AMI) and have everything working. The only problem is that the URL is very odd comprising a long string of numbers and letters.

I have a web name that I bought through Godaddy and I can redirect that to my Joomla instance, which takes me there but, once I get there, the URLs are back.

How do I set things up so that the Joomla pages follow my website name e.g. www.mywebsite.com instead of ec2-11-22-333-44.compute-1.amazonaws.com?

 
Avatar houldsworth1 14 post(s)

OK – don’t worry. I figured it out.

My problem was that I had not allocated an elastic IP address, so I couldn’t point my domain to it, and forwarding it allowed me to access it but not well enough for it to recognize the site as being from my URL.

Once I allocated an Elastic IP, and assigned that IP to my domain name, all worked. The only problem is that now, when I go to ‘mydomain.com’ it shows me the Bitnami banner instead of my site.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

I’m glad to hear that. Yes you have to assigned an elastic IP address to point to your domain. Take a look to this guide for changing the URL at http://wiki.bitnami.com/Applications/BitNami_Joomla!Stack#How_to_change_the_defaultURL.3f

 
Avatar houldsworth1 14 post(s)

Thanks. I did try that to change the URL but obviously did something wrong because afterward I couldn’t access the site at all.

I have a temporary solution, which is that I have changed the index.html file to put a redirect in the header to mysite.com/joomla – which is good enough for now.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Ok this is another possibility. Could you check the Apache log file at /opt/bitnami/apache2/logs/error.log ?

 
Avatar houldsworth1 14 post(s)

Will do. Right now I have a different issue. I am trying to get the mail function to work and I keep getting errors such as “SMTP Error! Could not connect to SMTP host.”

I have tried using phpmailer and SMTP with the same results.

This is an email address I am using from other sites without any problems. I have opened up the SMTP port (25) on the security in Amazon but still can’t seem to get through.
Have you had any experience with that?

 
Avatar houldsworth1 14 post(s)

Hmmm….and now I’m getting a message from Amazon telling me that I have reached the limit for sending emails through SMTP port 25. Frustrating considering that none of them actually went anywhere.

 
Avatar houldsworth1 14 post(s)

OK – I think I figured that one out too. Not sure why but I couldn’t get Optonline to accept SMTP, and Amazon didn’t seem to want to send more than a few emails through port 25 anyway. So I switched to using a Gmail account.
I first had to open port 465 on EC2 security, and then use the Gmail settings for SSL as follows:
Mailer : SMTP Server
Mail from : youremail@yourdomain ( Write your e-mail here )
From Name : My Name ( Write a normal name here )
Sendmail Path : leave it by default
SMTP Authentication : Yes
SMTP Security : SSL
SMTP Port : 465
SMTP Username : youremail@yourdmain ( Your Full e-mail address )
SMTP Password : YourEmailPassword
SMTP Host : smtp.gmail.com

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Thanks for posting your solution. My understanding is that it is not necessary to open the port in the Amazon firewall.

Forums Joomla!