This forum is no longer active. Please post your questions to our new community site

Forums Joomla!

Registration not working

Subscribe to Registration not working 8 post(s), 2 voice(s)

Avatar caru 4 post(s)

Hello all,
I just discovered the bitnami project, it rocks!

I am using an EBS amazon image, but I need to have /opt/bitnami/mysql and /opt/bitnami/apps/joomla on a different volume, so I just created 2 symbolic links to such directories in the new volume.
All works fine, but the registration page. I set up SMTP and all, but when a user hits the “Register” button nothing happens. The registration form just sits there. This must be a problem with the symbolic links, since everything works fine if I just use the EBS image as is.
Anyone has any idea what is the issue?

Thanks in advance, caru.

Avatar Beltrán Rueda Administrator 3,714 post(s)

It is strange, did you copy the folders with the same permissions? Could you post the error that you can see in the “apache2/logs/error_log” file?

Avatar caru 4 post(s)

Hi beltran,
The new volume is just a snapshot of a previous bitnami EBS instance, so the folders have the same permissions.

Unfortunately apache error log doesn’t show anything in this regard, and I can understand this, since clicking the register button or hitting enter is totally ignored. Even form validation is not performed.

Here some snippets from the rendered registration form:
>form action=“/joomla/index.php/component/user/” enctype=“multipart/form-data” method=“post” id=“josForm” name=“josForm” class=“form-validate”>

>div class="k2AccountPageUpdate">
>button class=“button validate” type="submit">


Please note that I am using the K2 login module, but using the standard one gives the same result.


Avatar Beltrán Rueda Administrator 3,714 post(s)


Is it possible that the problem is that the application can not send emails? Could you check the SMTP settings?

Avatar caru 4 post(s)

SMTP works fine. I set them in the configuration panel of Joomla. They work fine if I don’t use the external volume. As soon as I delete the joomla folder and make a link to the external volume, of course setting again the SMTP configuration, it doesn’t work.

Avatar Beltrán Rueda Administrator 3,714 post(s)

Sorry not sure. Could you configure the following line in the “/opt/bitnami/apps/joomla/htdocs/configuration.php” file and see if there is any log with more info?

var $log_path = ‘/var/logs’;

Avatar caru 4 post(s)

I checked that directory, didn’t exist. So I created one, and made daemon owner and group of it.
Now joomla sees it, and says that permissions are ok for that folder.
Then I tried again to hit the register button, but after that, issuing an “ls” in that directory shows that no file has been created…

PS: BTW I also checked configuration.php, and that line is there.

Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi Caru,

Sorry maybe you can find more help in the Joomla forums. I took a look and the culprit could be a plugin that you installed. For example,

Please post if you finally find the solution.

Forums Joomla!