This forum is no longer active. Please post your questions to our new community site

Forums Joomla!

Uploading files

Subscribe to Uploading files 7 post(s), 5 voice(s)

 
Avatar Otto 1 post

Tried to upload files, (pdf,doc.etc)does not work. checked permissions and size limit, nothing.

I went to the Joomla Forums and I found nothing, a lot of people are having problems with this Joomla! Version, I was thinking that since I didn’t find any solution on the Joomla Forums, you guys could help me.

I can upload any kind of Images (jpg,png,tiff) but I tried to upload files to make links to it and nothing works, I am nowhere now.

Thank you in advance.

 
Avatar antonio 621 post(s)

Hi Otto,

Unfortunately, we aren’t Joomla! experts, so you’ll need to provide extra information. How are you trying to upload files? Does it need to enable an external plugin? Can you post here the links to the Joomla! Forums threads that discuss this issue?

Thanks

 
Avatar jamessta 2 post(s)

I have given up trying to solve this problem and will revert to an earlier Joomla version.

To repro the issue – log in to the administrator area and attempt to upload a template or other extension to the app – upload fails.

btw – there are lots of different hints and tips here http://forum.joomla.org/viewtopic.php?t=225840 which may work for you but did not work for me :(

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Thanks for your reply. We will upload the Joomla! version if it fixes this issue.

 
Avatar soltrinox 2 post(s)

Ok, I am a very skilled LAMP developer, and this Joomla stack has some problems. I installed on EC2 but that does not matter.

I have gone over the settings and even run chgrp and chown the files inside the joomla directory to reflect ownership by daemon which is the user that apache threads run under. I noticed that when looking at the apache processes the master process is owned by root and the child processes are under daemon.

Could this be fouling up my ability to upload files, because the wrong user is trying to access the file that does not have permission?
Changing to root owned directory could be bad yes?

Any ideas why I can not upload anything at all?

Thanks

 
Avatar soltrinox 2 post(s)

Ok… here is the fix…..

run the following commands :

1] #bash: locate php.ini

should get — /opt/bitnami/php/etc/php.ini

2] #bash: nano /opt/bitnami/php/etc/php.ini

3] edit the line with

upload_tmp_dir =

to say

upload_tmp_dir = /opt/bitnami/apps/joomla/htdocs/tmp

Of course be sure that the

/opt/bitnami/apps/joomla/htdocs/tmp

directory exists.

Finally

4] #bash: apachectl restart

and my problem was fixed…..

Dylan Rosario

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Thanks for posting the solution. We have also a Joomla EC2/EBS instance which have the permissions already configured to you can manage from your computer using WinSCP or a similar program. You can find more info at http://wiki.bitnami.com/Amazon_Cloud_Images_Qui…

Let me ask you a question. Why are you using your own instance and installing the Stack on top of it instead of using the already done Joomla instances? Thanks.

Forums Joomla!