This forum is no longer active. Please post your questions to our new community site

knowledgetree-3.5.2-beta1 error

Subscribe to knowledgetree-3.5.2-beta1 error 5 post(s), 3 voice(s)

 
Avatar jersinghaus 1 post

Hello,

I just installed 3.5.2-beta1 on a centos5 box and I get this error when accessing the kt url:

Error type Failed to create log file /opt/knowledgetree-3.5.2-beta1-1/apps/knowledgetree/var/log/log-2008-02-02.nobody.txt (check permissions)

I know it’s beta, but your help would be appreciated.

Thanks,
Joe

 
Avatar antonio 621 post(s)

Can you check the permissions in that folder? You will probably need to grant write permissions to everyone on it. We’ll fix this asap

Cheers!

 
Avatar adot 2 post(s)

G’Day,

I think I’ve got a related problem.

I installed the KT-Stack under Mac OSX 10.4 and everything ran fine. After restarting my machine I started the Stack using

sudo sh /Applications/knowledgetree-3.5.2-beta1-1/ctlscript.sh start

But when accessing KT I get following error:

Failed to create log file /Applications/knowledgetree-3.5.2-beta1-1/apps/knowledgetree/var/log/log-2008-02-20.nobody.txt (check permissions)

I set the permissions of the appropriate folder to 777 and ran

sudo sh /Applications/knowledgetree-3.5.2-beta1-1/ctlscript.sh restart

and get following output:

localhost:/Applications/knowledgetree-3.5.2-beta1-1 dahaarhoff$ sudo sh ctlscript.sh restart
Syntax OK
/Applications/knowledgetree-3.5.2-beta1-1/apache2/scripts/ctl.sh : httpd stopped
/Applications/knowledgetree-3.5.2-beta1-1/mysql/scripts/ctl.sh : mysql not running
/Applications/knowledgetree-3.5.2-beta1-1/mysql/scripts/ctl.sh : mysql started at port 3306
Starting mysqld.bin daemon with databases from /Applications/knowledgetree-3.5.2-beta1-1/mysql/data
STOPPING server from pid file /Applications/knowledgetree-3.5.2-beta1-1/mysql/data/localhost.pid
080220 20:10:59 mysqld ended

Syntax OK
/Applications/knowledgetree-3.5.2-beta1-1/apache2/scripts/ctl.sh : httpd started at port 8080

And I still get the error message when trying to access KT.

I’m guessing it’s got something to do with mysql being stopped. But couldn’t figure out why…

Thanks,

Roger

 
Avatar antonio 621 post(s)

Hi Roger,

Can you please look at (and post here) the contents of the mysql log file? It’s located at /Applications/knowledgetree-3.5.2-beta1-1/mysql/data

Cheers

 
Avatar adot 2 post(s)

Okay my bad.

After rebooting I started the stack without sudo and everything works fine.

So all that needs doing is to fix the permissions on the log folder.

I guess I still got the error message due to not flushing my cache and httpd not being able to serve up something new. I don’t know. I guess the good old principle of “Have you tried turning it on and off again?” isn’t so old after all.

If you still need that log let me know.