This forum is no longer active. Please post your questions to our new community site

Upgrade to newer version

Subscribe to Upgrade to newer version 11 post(s), 5 voice(s)

Avatar bostonvaulter 4 post(s)


I installed the KnowledgeTree bitnami stack a few months ago and would now like to upgrade to the latest version. How do I do this?

I can install the newer version okay, but when I try to port over the old database, it does not work.

Avatar victoria Administrator 134 post(s)


Which error are you receiving when trying to import the old database? Which version the BitNami KnowledgeTree Stack did you have before?

Avatar bostonvaulter 4 post(s)

Hi Victoria,

I am currently using Bitnami stack version KnowledgeTree Version 3.5.2 (Community Edition) on Mac OS X 10.5.7. If I drop the original tables on the new bitnami knowledgetree stack version 3.6.1 and import the old tables this is the error I get:

Fatal error: require_once() [function.require]: Failed opening required ‘/Applications/knowledgetree-3.6.1-1/apps/knowledgetree/htdocs//Applications/knowledgetree-3.5.2-2/apps/knowledgetree/htdocs/plugins/ktcore/KTCoreLanguagePlugin.php’ (include_path=‘/Applications/knowledgetree-3.6.1-1/apps/knowledgetree/htdocs/search2:/Applications/knowledgetree-3.6.1-1/apps/knowledgetree/htdocs/ktapi:/Applications/knowledgetree-3.6.1-1/apps/knowledgetree/htdocs/thirdparty/xmlrpc-2.2/lib:/Applications/knowledgetree-3.6.1-1/apps/knowledgetree/htdocs/thirdparty/simpletest:/Applications/knowledgetree-3.6.1-1/apps/knowledgetree/htdocs/thirdparty/Smarty:/Applications/knowledgetree-3.6.1-1/apps/knowledgetree/htdocs/thirdparty/pear:/Applications/knowledgetree-3.6.1-1/apps/knowledgetree/htdocs/thirdparty/ZendFramework/library:.:/Applications/knowledgetree-3.6.1-1/php/lib/php’) in /Applications/knowledgetree-3.6.1-1/apps/knowledgetree/htdocs/lib/plugins/ on line 200

Since it mentions the path of the old installation for 3.5.2 I think I need to do the export and import differently somehow. I believe I was following this guide:…

Which doesn’t really talk about updating, but I hoped it would work. I can’t seem to find any guides about updating the bitnami stack, there is some type of updater for normal stack installs and source-only installs but they won’t work directly for the bitnami stack.

Thanks for your help.


Avatar bostonvaulter 4 post(s)

Is there some sort of upgrade method for the bitnami knowledgetree stack? I haven’t been able to find anything.

Avatar Beltrán Rueda Administrator 3,714 post(s)


No, there is not a defined method for BitNami Stack, you should update the stack following the official steps for KnowledgeTree application.


Avatar bostonvaulter 4 post(s)

When I try knowldetree’s official upgrade method I get an error connecting to the database.

Here are the instructions:…

And this is the error:

[db_error: message=“DB Error: insufficient permissions” code=-26 mode=return level=notice prefix="" info=" [nativecode=Access denied for user ’dmsadmin’@’localhost’ to database ‘dms_bitnami’] ** Array"]

Edit: I’m able to fix it by giving dmsadmin permission for everything on the dms_bitnami table, but just realized I missed the first couple steps of the instructions listed above.

Edit: I’m having trouble with the following two steps:
1. Download the latest source code and extract.
2. Upload and overwrite your existing KT code.

Because the bitnami stack is a stack install rather than just source code, it is hardwired for where I first install it. So if I copy everything from the new folder into the old one it erases the old database and everything. I’m going to give up for today.

Avatar victoria Administrator 134 post(s)


I just upgraded a BitNami KnowledgeTree stack following the steps in the url you provided. I used the ‘via url’ mode. However, before overwritting the files with the new version I made a backup of the /apps/knowledgetree/htdocs/config/config.ini and after overwritting the old version of KnowledgeTree I restored this file. This file includes the database connection settings so you shouldn’t have any issue with the database connections.

Could you try this and let as know if you get it working?


Avatar timheger 5 post(s)

What is the suggested process for upgrading the OSX version? Obviously the KT installers don’t work on OSX….

Avatar rraarr 3 post(s)


this is my first post here. i’m havin’ troubles in my knowledgeTree (KT) 3.6.1 stack, installed on a debian lenny 32 bit.
the main problem is that the ../tmp folder grows in a massive way (40 Gb) and hangs up when i try to realize a ‘bulk download’ or ‘download all’, ( KT hangs up like windows, but i’m in LINUX, jajaja lololol)

i’ve been reading in official forums (knowledgetree) and they said that this error is caused by scheduler, because all ‘download all’ orders, goes to a queue managed by this one and this bug is fixed in newer versions (3.6.3), so i think that i’m going to uninstall my stack and try with newest one 3.7.0

my question is, How can i uninstall my actual stack and install the newest one?? is there any method to uninstall automatically my installed stack??

thank you all

Avatar Beltrán Rueda Administrator 3,714 post(s)


The best way to upgrade is:

1. Backup the database
2. Stop the servers
3. Install the new version
4. Restore the database
5. If everything goes well, remove the previous installation