This forum is no longer active. Please post your questions to our new community site

Forums LAMPStack

LAMPStack installation in Fedora 14

Subscribe to LAMPStack installation in Fedora 14 6 post(s), 4 voice(s)

 
Avatar rdtech25 1 post

Recently I have tried to install LAMPStack over Fedora 14 but due to some unknown errors failed. What way should I install LAMPStack, so that I can run it on my local machine smoothly.

 
Avatar carlos Administrator 144 post(s)

Hi,

Could you give us more details about what kind of errors did you get?

 
Avatar Rodrigo 25 post(s)

Hi, same problem here? I’m trying to install Lamp stack 1.2-4 in Fedora 14.
I’ve run the .bin installation file with root powers.
Installation setup runs till 100%, but then an error window pops up with the following message:

Error running /opt/lampstack-1.2-4/mysql/scripts/myscript.sh /opt/lampstack-1.2-4/mysql **** : bin/mysql.bin: error while loading shared libraries: libncursesw.so.5: cannot enable executable stack as shared object requires: Permission denied
bin/mysql.bin: error while loading shared libraries: libncursesw.so.5: cannot enable executable stack as shared object requires: Permission denied
bin/mysql.bin: error while loading shared libraries: libncursesw.so.5: cannot enable executable stack as shared object requires: Permission denied

I can press the OK button in this error window and finish the setup (apparently)
Now I try to install a module ontop (e.g.: coppermine module) of the stack, also executing the .bin with root privileges.
I select the stack path, but when I’m creating the admin account, it does not accept the mySQL password (I’m writing down the password I used for the MySQL root user during the installation of the stack). It gives me the following error: “Please introduce a valid password to connect to the MySQL server.”

I guess is due to the former error during the stack install ??

I would like to know if this happens only in Fedora, I have no chance to test with other distros right now.

Thanks in advance
Rod

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

This seems a SELinux issue. Could you try to run the following command as a root user before installing the Stack?

# /usr/sbin/setenforce 0

Thanks for reporting it, we will fix it for next releases.

 
Avatar Rodrigo 25 post(s)

Eres un crack!!

Works perfectly in Fedora14 setting permisive SELinux before the installation

I confirm you that the error occurs only in Fedora, I tried to install the LAMP Stack in Ubuntu 10.04 and everything goes smoothly.
Bitnami technical support is excellent, I will write a praise post in the forum, everybody should now that..

Cheers,
Rod

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Muchas gracias! I’m glad to hear that :)

Forums LAMPStack