This forum is no longer active. Please post your questions to our new community site

Forums MAMPStack

Apache can't start

Subscribe to Apache can't start 4 post(s), 2 voice(s)

 
Avatar jpbaril 2 post(s)

I installed MAMPStack in graphic mode as an admin user in /Applications (and also tried in my home folder) but at the end I got an error when the installer tried to start Apache. It says httpd could not be started.
If I then use the ./ctlscript.sh script in the terminal with sudo, I can start Apache. Why can’t I start Apache as an admin user in graphic mode ? Because I can’t then use the control panel app to start Apache.
Also, because of this, it seems phpMyAdmin password is not set as said in the readme.txt.
All is fine with mysql though.

Tke Apache log:

[Tue Jul 14 20:54:17 2009] [error] (13)Permission denied: Cannot create SSLMutex
Configuration Failed

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

It is strange, we can not reproduce on our side. If you want to manage servers using the control panel you should start it as root user.

 
Avatar jpbaril 2 post(s)

I think I found the problem, but maybe it’s not related and I’m just lucky.
Because I could not easily run Apache, I installed xampp for Mac. It told me there was a problem with my host file causing Apache to not start. But then, the installer made a change to that file, it added the name of my machine to the host file, like “127.0.0.1 name_of_machine”. Xampp Apache then started. I retried Bitnami as a normal user, and it worked.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Thanks for reporting it. This post will be very helpful for other users.

Cheers.

Forums MAMPStack