This forum is no longer active. Please post your questions to our new community site

Forums Mantis

Mail Doubt

Subscribe to Mail Doubt 11 post(s), 3 voice(s)

 
Avatar lokazouy 1 post

Hi,

I have been using the bitnami mantis virtual appliance and I had some problems configuring the mail. According to mantis guide the methods to mail by are three:
0 – mail()
1 – sendmail
2 – SMTP

Which one should I use If I don’t want to use any external SMTP server? Which extra configuration should I add?

Thanks in advanced

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

To use an external SMTP server you should use the SMTP method. You can configure the SMTP parameters: user, password, port and authentication method in the Mantis configuration file: installdir/apps/mantis/htdocs/config_inc.php

 
Avatar crp 13 post(s)

I am trying to get the email work , with no luck. I want to use the sendmail on the box that the bitnami is running on.

[bitnami@rh5 ~/lampstack-1.2-4]$ cat apps/mantis/htdocs/config_inc.php
<?php
$g_hostname = ‘localhost’;
$g_db_type = ‘mysql’;
$g_database_name = ‘bitnami_mantis’;
$g_db_username = ‘bn_mantis’;
$g_db_password = ‘314d649661’;

$g_phpMailer_method = 1; $g_from_email = ‘tracker@bats123.com’; $g_allow_file_upload = OFF; $g_window_title = ‘MantisBugTracker’;

?>

sendmail is working on the machine as there are scripts that are running that have the email being sent out and alpine is working just fine.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Maybe it is necessary to create a task in the cron. http://www.mantisbt.org/wiki/doku.php/mantisbt:…

 
Avatar crp 13 post(s)

okay, i reinstalled the LAMP and mantis as the system’s root.
The config_inc.php now reads
<?php
$g_hostname = ‘localhost’;
$g_db_type = ‘mysql’;
$g_database_name = ‘bitnami_mantis’;
$g_db_username = ‘bn_mantis’;
$g_db_password = ‘c210c121cf’;
$g_phpMailer_method = 1;
$g_from_email = ‘bitnami’;
$g_allow_file_upload = OFF;
$g_window_title = ‘MantisBugTracker’;
?>

I then do: php /opt/lampstack-1.2-5/apps/mantis/htdocs/scripts/send_emails.php
and it fails with the following:

APPLICATION ERROR #400

APPLICATION ERROR #400

Database connection failed. Error received from database was #1045: Access denied for user ’bn_mantis’@’localhost’ (using password: YES).

Please use the “Back” button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.

Previous non-fatal errors occurred. Page contents follow.

SYSTEM WARNING: mysql_connect(): Access denied for user ’bn_mantis’@’localhost’ (using password: YES)

Yet Mantis is running and responding.
So what is going on?

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

That is strange, could you check if you can connect to mantis database using the command line?

mysql -u bn_mantis -p

and write the “db_password”.

 
Avatar crp 13 post(s)

What is the password for bn_mantis supposed to be? The only password I recall setting up was for the administrative user, but that does not work.
[root@rh5 ~]# mysql -P3316 -u bn_mantis -p
Enter password:

ERROR 1045 (28000): Access denied for user ’bn_mantis’@’localhost’ (using password: YES)

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

In you case “c210c121cf”

 
Avatar crp 13 post(s)

oh. I thought c210c121cf was a mask for the real password.

okay,
“mysql -h url.name.com -P3316 -u bn_mantis -p”
gives a result of:
ERROR 1130 (00000): Host ‘url.name.com’ is not allowed to connect to this MySQL server
which makes sense.
but
“mysql -P3316 -u bn_mantis -p”
still gives a result of
ERROR 1045 (28000): Access denied for user ’bn_mantis’@’localhost’ (using password: YES)

 
Avatar crp 13 post(s)

well this comes under the heading of What The Heck ???

_[root@rh5 htdocs]# ping localhost PING localhost (127.0.0.1) 56(84) bytes of data. 64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.055 ms 64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.061 ms 64 bytes from localhost (127.0.0.1): icmp_seq=3 ttl=64 time=0.059 ms 64 bytes from localhost (127.0.0.1): icmp_seq=4 ttl=64 time=0.056 ms_

for some reason (desperation?) I made the following changes to the config_inc.php

“<?php $g_hostname = ‘127.0.0.1:3316’; $g_db_type = ‘mysql’; $g_database_name = ‘bitnami_mantis’; $g_db_username = ‘bn_mantis’; $g_db_password = ‘edffc3231e’; $g_email_send_using_cronjob = ON; $g_phpMailer_method = 1; $g_from_email = ‘bitnami’; $g_allow_file_upload = OFF; $g_window_title = ‘MantisBugTracker’; ?>"

Then I did
[root@rh5 htdocs]# php /opt/lampstack-1.2-5/apps/mantis/htdocs/scripts/send_emails.php
which resulted in
Sending emails…
Done.

And the MantisBT web interface still works.

:?: :?: :?: Can anyone explain :?: :?: :?:

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

I’m glad to hear that. We will check the problem.

Forums Mantis