This forum is no longer active. Please post your questions to our new community site

Forums Mantis

MySQL login

Subscribe to MySQL login 12 post(s), 2 voice(s)

 
Avatar reinderotter 8 post(s)

Hi,

I tried to login to MySQL database, but didnt seem to work. So I treid to change the pwd (by using CMD and something with copying passwords (didnt work as well so I hardcopied the password:)).

Finally I got in and tried to change the root user password….BIG problem, because I now am shut out of the database (it opens but then access denied for everything….)

Anyone any idea how to solve this?

Next to this, what is the login for Mantis? Because I used administrator / root (default mantis), but that doesnt work.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Please take a look this quick guide . You should run the mysql command from the BitNami console. Which platform and what installer, virtual machine or AMI are you using?

 
Avatar reinderotter 8 post(s)

Using AMI ID: ami-df85b1ab (Windows 2008 server with Mantis 1.24 installed). Can you tell me how to reset the passwords for PHPMyAdmin? And what the login for mantis is? Cant seem to find this.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

The Mantis administrator user is “user” and the password “bitnami”. You can find it in the mantis download page in BitNami. PHPMyAdmin is not enabled by default. You can find hot to enable it at http://wiki.bitnami.com/Components/phpMyAdmin_a…

 
Avatar reinderotter 8 post(s)

Ok, I got in the hardcode way and changed the password for the “root” user for localhost, but then got the following message:

Error
MySQL said:

  1. - Access denied for user ’root’@’localhost’ (using password: YES)

How can I get in again? :)

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Are you trying to access remotely? In this case you should configure MySQL properly. Take a look at http://wiki.bitnami.com/Components/MySQL#How_to_connect_to_the_MySQL_database_from_a_different_machine.3f Is it work from the same machine?

 
Avatar reinderotter 8 post(s)

No I logged in through Remote Desktop, so directly on the machine itself….

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Sorry, that’s really strange. Please check that you are running the /opt/bitnami/mysql/bin/mysql binary. Maybe your password requires to scape a character.

 
Avatar reinderotter 8 post(s)

I think I need to rephrase; The login I’m using from the “user” file in the apache2 map seems to work (administrator). However, I then get a phpmyadmin error. This is because in an earlier stage, I changed the password of the user “root@localhost” and then got locked out :( See att. for the error.

 

Attached Files

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Ah ok,

In this case you have to set the new root password in the apps/phpmyadmin/htdocs/config.inc.php file.

 
Avatar reinderotter 8 post(s)

Cheers! That seemed to do the trick :)

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

I’m glad to hear that!

Forums Mantis