This forum is no longer active. Please post your questions to our new community site

Forums MediaWiki

error during installation - problem copying LocalSettings.php

Subscribe to error during installation - problem copying LocalSettings.php 36 post(s), 9 voice(s)

Pages: « Previous 1

 
Avatar mwnorman 4 post(s)

Using the bitnami-mediawiki-1.11.0-4-windows-installer, I tried to install
MediaWiki. Everything seemed to go OK until the very end, when a message
popped-up:

Cannot copy C:\Program Files\BitNami MediaWiki Stack\apps\mediawiki\conf\LocalSettings.php to
C:\Program Files\BitNami MediaWiki Stack\apps\mediawiki\htdocs\LocalSettings.php

the reason (naturally!) is that LocalSettings.php doesn’t existing in the conf
directory.

It is my understanding that this file is generated by the installer??

Anyhuu … is there a ‘default’ LocalSettings.php I can use?

Thanks in advance,

Mike Norman

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi Mike,

I can’t reproduce this issue. It seems that is a time error. The installer try to copy this file before it has been created. Can you repeat the installation without secondary process are running?

 
Avatar mwnorman 4 post(s)

Sure – I haven’t done anything with it yet, so I’m not losing any data …

 
Avatar mwnorman 4 post(s)

Well, I shutdown everything, including the Symantec real-time virus checker – and I got the same error.
I’m on a Dell OptiPlex GX-620, Win XP-Pro(SP2), Pentium P4(HT) 2.8GHz/2Gb ram, so I don’t think it is
a CPU/filesystem problem.

Other than that, everything else seemed to install fine – I have services for MySQL and Apache2

MWN

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Yes, it’s probably that the system is not the problem. Have you used strange characters into the parameters? Can you try with others parameters? Thanks.

 
Avatar mwnorman 4 post(s)

Well, I tried moving to the MediaWiki 1.11.0-5 installer and changed the target directory to c:\wamp – still
didn’t work.
So, I got the bitnami-wampstack-0.9.3-windows-installer.exe and installed it – everything went fine.
I then manually installed mediawiki-1.11.0.tar.gz under C:\WAMP\apps, and did the manual configuration
of MediaWiki which FINALLY generated the LocalSettings.php (whew!)

 
Avatar Daniel Lopez Administrator 140 post(s)

Hi,

I am glad that you got it working. We still need to track down the issue with the MediaWiki stack on our side, so it all works out of the box

 
Avatar ZackDRipper 1 post

Hi iam getting the same error trying to install bitnami-mediawiki-1.11.0-6-linux
i am trying to install it on OpenSUSE 10.3
I am also a linux n00b…

help please

 
Avatar antonio 621 post(s)

Hi,

I have enabled some debugging options and I’m currently creating new installers. I’ll let you know when they’re ready

Cheers

 
Avatar antonio 621 post(s)

A new version of MediaWiki has been released, you can download it from the stack page. Try installing it, and after that post here the contents of the file ‘postresult.html’, present in the main installation folder. Thanks

 
Avatar Imsdal 8 post(s)

I received the same error just now. I have previously installed this at home on Vista and Ubuntu, and both worked without any problems what so ever. This install was at work and on XP.

This is the result from postresult:
The requested URL could not be retrieved


While trying to retrieve the URL: http://npopc054:8081/mediawiki/config/index.php

The following error was encountered:

Unable to determine IP address from host name for npopc054
The dnsserver returned:

Server Failure: The name server was unable to process this query.
This means that:

The cache was not able to resolve the hostname presented in the URL. 
Check if the address is correct. 
Your cache administrator is webmaster.
 
Avatar antonio 621 post(s)

Hi Imsdal, I will look into this as soon as possible. This seems to be the same issue that is happening here I haven’t been able to reproduce it in the past, so any extra info that you can give us about the environment (specific version of XP, firewall used, etc) would help. Thanks

 
Avatar Imsdal 8 post(s)

It may be the same or a related problem, yes. I added the line to the hosts file, but received the same result.

I’m running XP SP2. The Windows Firewall service is not running. The computer is a part of my work network, and I have almost no idea how that is configured. Sorry…

 
Avatar antonio 621 post(s)

Are you using a proxy server? I’m going to change one thing and create a beta installer. Do you have any problems on testing it?

 
Avatar antonio 621 post(s)

Here you are

https://bitnami.com/files/tmp/bitnami-mediawiki-1.11.0-7-windows-installer.exe

 
Avatar Imsdal 8 post(s)

Yes, I am using a proxy. Maybe I should set it up to not use a proxy for certain local addresses? What, in that case? I am not usnig proxies at home where everything worked, so that’s a definite candidate area

I tried the new installer, but received the same error message, unfortunately.

 
Avatar antonio 621 post(s)

Try to add exceptions for addresses beginning with 127.0.0.1 and npopc054 and installing it again. If that doesn’t work, I have changed the installer again so the http requests are done to your machine ip address. I don’t really think that will work (if your proxy is not in your LAN network it won’t, definitely), but it’s worth the try. You can find it at https://bitnami.com/files/tmp/bitnami-mediawiki-1.11.0-BETA-windows-installer.exe

 
Avatar Imsdal 8 post(s)

First of all a big thank you for the time you take trying to resolve this. Much appreciated!

I added both 127.0.0.1 and npopc054 to the exceptions lists, but unfortunately, the installs still doesn’t work. The original fails in the same way as earlier, and the new one crashes harder.

Anyway, it would seem to me like the install is almost there. Now I can navigate to http://127.0.0.1:8087/mediawiki/ which gives me this message:
-
MediaWiki 1.11.0
Please set up the wiki first.
-

“Set up the wiki” is a working link to a setup page. It has a bunch of options, but just leaving them in and klicking install leaves this message:

-
Checking environment…
Please include all of the lines below when reporting installation problems.

PHP 5.2.5 installed
Found database drivers for: MySQL
PHP server API is apache2handler; ok, using pretty URLs (index.php/Page_Title)
Have XML / Latin1-UTF-8 conversion support.
Session save path (C:/PROGRA1/BI65D41/php/tmp) appears to be valid.
PHP’s memory_limit is 128M.
Couldn’t find Turck MMCache, eAccelerator, APC or XCache; cannot use these for object caching.
GNU diff3 not found.
Found GD graphics library built-in, image thumbnailing will be enabled if you enable uploads.
Installation directory: C:\Program Files\BitNami MediaWiki Stack7\apps\mediawiki\htdocs
Script URI path: /mediawiki
Installing MediaWiki with php file extensions
Environment checked. You can install MediaWiki.
Warning: $wgSecretKey key is insecure, generated with mt_rand(). Consider changing it manually.
Generating configuration file…

Database type: MySQL
Loading class: DatabaseMysql
Attempting to connect to database server as bitnami…success.
Connected to 5.0.45-community-nt-log
Error selecting database mediawiki_bitrock: 1044 Access denied for user ‘bitnami’@’localhost’ to database ‘mediawiki_bitrock’


This last piece should be manually correctable, I think, but I have no idea what to do about it.

Also, please tell me how to manually deinstall all the services from the failed installs. I have seven instances each of apache and MySQL. They are stopped, but I’d like them completely uninstalled.

 
Avatar antonio 621 post(s)

Thanks to you, I fixed a bug with the information you provided me with. I’ll release new MediaWiki installers as soon as I build them. I will fill the database configuration fields at installation time, so it should be easier for you to finish the installation wizard.

Deleting services on Windows is done from the command line (Start -> Run -> cmd.exe). Type

sc delete nameOfTheService

I will get back to you in a while with new installers

 
Avatar Imsdal 8 post(s)

Thanks. You guys rock!

I spent a bunch of hours some months ago trying to install MediaWiki without your stacks and got absolutely nowhere, so the service you provide is really valuable. Keep up the good work!

 
Avatar antonio 621 post(s)

New version released. The installer will still fail, but you should be able to set up the wiki. The installer will fill the database configuration fields, you will only need to choose the wiki name. If you face a problem similar to “config folder not present”, you will need to move the config folder from C:\(installation dir)\apps\mediawiki to C:\(installation dir)\apps\mediawiki\htdocs

I hope it works this time :)

 
Avatar Imsdal 8 post(s)

I am now happy to report a complete success.

The installer still failed in the same way as above, but navigating to localhost:<port>/mediawiki gave a link to the setup page, and that page worked. I then copied the LocalSettings.php file as per the instructions and everything is now up and running.

Thanks!

 
Avatar antonio 621 post(s)

You’re welcome :)

 
Avatar antonio 621 post(s)

Hey Imsdal. Could you please do some tests for us? We’re trying to track the issue with proxies. Can you check “Bypass proxy for local addresses” (or something like that) option in Internet Options and try installing the stack again? Also, if you could post here what options you have enabled and disabled in the proxy settings, that would be terrific :) Thanks a lot

 
Avatar Imsdal 8 post(s)

I can do some tests, but they may not be completely exhaustive – my IT dept already hates my guts for mucking around with my work computer far more than what is allowed… :)

My proxy setup is currently like this (all this from IE7, which is the only browser available on this machine):

LAN settings: Automatically detect settings selected

Use a proxy server for LAN is checked. Address and port filled in, Bypass proxy for local addresses is not checked.

I seem to remember having some issues with things not working well when having that one checked previously. I will do some tests and get back to you.

Under advanced settings, I have a bunch of exceptions, including 127.0.0.1 and npopc054 which has been added after this thread started. I have seen no ill effects from that so far.

Just to make sure: If I run the installer again, it will install new versions of apache and MySQL on new ports, so it shouldn’t harm my current installation in any way, right? I have already spent quite some work time on this and would hate to see that wasted…

 
Avatar antonio 621 post(s)

Thank you very much. Yes, if you install it again and your other installation servers are already running, you will be asked for new ports for Apache and MySQL. You can delete the exceptions I told you to add (they’re not working anyway), and please enable “Bypass proxy for local addresses”. Again, thanks!

 
Avatar Imsdal 8 post(s)

I checked ty bypass check box and installed again. The results are, as far as I can tell, exactly the same: the error message, go to setup page, click install, move localsettings.php up one level and then everything looks fine.

So no difference there, unfortunately.

 
Avatar antonio 621 post(s)

Ouch :( Well, it was worth the try. Thank you very much, we’ll keep investigating this issue

 
Avatar pfoomer 16 post(s)

Hi

fresh install of mampstack 1.2.1-1, followed by latest mediawiki bitnami-mediawiki-1.15.3-0-module-osx-x86-installer.app
gets me the original poster error, on 10.6.3.

Then trying to set up wiki gets me
Your system has a combination of PHP and libxml2 versions which is buggy and can cause hidden data corruption in MediaWiki and other web apps. Upgrade to PHP 5.2.9 or later and libxml2 2.7.3 or later! ABORTING (http://bugs.php.net/bug.php?id=45996 for details).

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Yes this is a know issue. We will update MAMPStack to the latest version of PHP and libxml. The Mediawiki Stack has already the latest version of these dependencies.

Next Page

Pages: « Previous 1

Forums MediaWiki