This forum is no longer active. Please post your questions to our new community site

Forums MediaWiki

error during installation - problem copying LocalSettings.php

Subscribe to error during installation - problem copying LocalSettings.php 36 post(s), 9 voice(s)

Pages: « Previous 1 2 Next »

 
Avatar roemisch 1 post

I try to install MediaWiki on the Ubuntu 10.04 LAMP stack and I get the an error during the install routine saying that:
" Error renaming /opt/bitnami/apps/mediawiki/htdocs/config/LocalSettings.php to /opt/bitnami/apps/mediawiki/htdocs/LocalSettings.php".
The file /opt/bitnami/apps/mediawiki/htdocs/config/LocalSettings.php does not even exist when I check the directory.
After the installation when I try to start the MediaWiki Module, on the next screen it says:
“Your system has a combination of PHP and libxml2 versions which is buggy and can cause hidden data corruption in MediaWiki and other web apps. Upgrade to PHP 5.2.9 or later and libxml2 2.7.3 or later! ABORTING (http://bugs.php.net/bug.php?id=45996 for details). "
How can this be fixed ?

I also cannot see any mediawiki database or database user in mysql being generated – is that because the installation scripts stops after the renaming error ?

Help is very appreciated !

Thank you,

Rudi Römisch

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

This is a known issue. We have updated the Mediawiki Stack but not the LAMP Stack yet. Could you install the Mediawiki Stack instead of the LAMP Stack module?

 
Avatar dflexer 2 post(s)

Hi

Has this been fixed? I am trying to install bitnami-mediawiki-1.16.0-0-module-linux-installer.bin over bitnami-rubystack-2.1-0-linux-installer.bin on Ubuntu 10.10. Rubystack installed fine, then when I tried to install Mediawiki over it fails with this same error:

Welcome to the BitNami MediaWiki Module Setup Wizard.
-————————————————————————————————————-
Installation folder
Please choose a folder that contains an installation of BitNami LAMPStack.
Select a folder []: /opt/rubystack-2.1-0/
-————————————————————————————————————-
Create Admin account
Login [user]: wiki
Your real name [User Name]: Wiki Administrator
Email Address [user@example.com]: xxxx@xxxx.com
Please enter the existing MySQL password for BitNami LAMPStack
Password :
-————————————————————————————————————-
MediaWiki
Please configure MediaWiki installation
Wiki name [wiki’s Wiki!]: XXXX
-————————————————————————————————————-
Setup is now ready to begin installing BitNami MediaWiki Module on your computer.
Do you want to continue? [Y/n]:
-————————————————————————————————————-
Please wait while Setup installs BitNami MediaWiki Module on your computer.
Installing
0% ______________ 50% ______________ 100%
########################################Warning: Problem running post-install step. Installation may not complete
correctly
Error renaming
/opt/rubystack-2.1-0/apps/mediawiki/htdocs/config/LocalSettings.php to
/opt/rubystack-2.1-0/apps/mediawiki/htdocs/LocalSettings.php
Press [Enter] to continue :
#
-————————————————————————————————————-
Setup has finished installing BitNami MediaWiki Module on your computer.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

No sorry, this issue will be fixed when we release a new rubystack version. Please use the full Stack installer or complete the Mediawiki wizard to install them.

 
Avatar dflexer 2 post(s)

I would rather not install the full Mediawiki stack since I need to install other modules that I want to share the Rubystack component.

I do not know how to run the wizard you are referring to. Is it documented or can you provide brief instructions?

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

We released a new module for Mediawiki yesterday. Could you try to download and install it again? Thanks.

Pages: « Previous 1 2 Next »

Forums MediaWiki