This forum is no longer active. Please post your questions to our new community site

Forums Redmine

Can't install on x86 Synology NAS

Subscribe to Can't install on x86 Synology NAS 10 post(s), 2 voice(s)

 
Avatar derekcharles 6 post(s)

I selected all the default options on the latest release (1.1.2-1 linux) on my Intel Atom-based Synology DS710+ (running DSM 3.0), under BusyBox.

This is what I get:

BusyBox v1.16.1 (2010-12-23 02:46:26 CST) built-in shell (ash)
Enter ‘help’ for a list of built-in commands.

Station> ./bitnami-redmine-1.1.2-1-linux-installer.bin
-————————————————————————————————————-
Welcome to the BitNami Redmine Stack Setup Wizard.


Installation folder

Please, choose a folder to install BitNami Redmine Stack

Select a folder [/opt/redmine-1.1.2-1]:


Create Admin account

BitNami Redmine Stack admin user creation

Login [user]: derek

Password :
Please confirm your password :
Your real name [User Name]: **** *

Email Address [mail@example.com]: ****@****.com


Web Server Port

Please enter the port that the bundled Apache Server will listen to by default.

Apache Web Server Port 80: 80

Warning: Unable to bind to the given port number. Please select another one.
Press [Enter] to continue :
-————————————————————————————————————-
Web Server Port

Please enter the port that the bundled Apache Server will listen to by default.

Apache Web Server Port 80: 8080


Language for default data configuration

Select your language for default data configuration:

1 Bulgarian
2 Czech
3 German
4 English
5 Spanish
6 French
7 Hebrew
8 Italian
9 Japanese
10 Korean
11 Dutch
12 Polish
13 Portuguese
14 Portuguese/Brazilian
15 Romanian
16 Russian
17 Serbian
18 Swedish
19 Chinese
20 Chinese/Taiwan
Please choose an option 4 :

SMTP Configuration

Do you want to configure SMTP server?

1 yes
2 no
Please choose an option 2 :


Setup is now ready to begin installing BitNami Redmine Stack on your computer.

Do you want to continue? [Y/n]: Y


Please wait while Setup installs BitNami Redmine Stack on your computer.

Installing 0% ______________ 50% ______________ 100% ########################################

Error: There has been an error.
Error running stat -format=%a /opt/redmine-1.1.2-1/perl/bin/c2ph : stat:
unrecognized option `
-format=%a’
BusyBox v1.16.1 (2010-12-23 02:46:26 CST) multi-call binary.

Usage: stat [OPTIONS] FILE

Display file (default) or filesystem status

Options:
-f Display filesystem status
-L Follow links
-t Display info in terse form

Press [Enter] to continue :
Station>

if I try to run ctlscript.sh status, I get this:

Station> cd /opt/redmine-1.1.2-1/
Station> ./ctlscript.sh status
subversion not running
/opt/redmine-1.1.2-1/apache2/scripts/ctl.sh: .: line 15: can’t open ‘/opt/redmine-1.1.2-1/apache2/scripts/envvars’
mysql not running
Station>

Anyone have any ideas?

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Sorry but it seems BusyBox does not support some commands and in this case it seems that does not fully support perl.

 
Avatar derekcharles 6 post(s)

So is that it? I can’t do anything? Or can I alter the scripts to suit the reduced BusyBox functionality? Where do I look?

Thanks.

 
Avatar derekcharles 6 post(s)

It looks like this failure is simply because BusyBox stat doesn’t support the —format switch rather than Perl as a whole. Presumably this is where the script stops and there’s a whole bunch of stuff it’s supposed to do afterwards but isn’t. Surely this is something I can easily fix if I know where to look? Or is this just the start of a mountain of trouble?

Perl is formally included with Synology so the support should be pretty comprehensive.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

You can create a small fix as a workaround:

1. Create a “stat” script whith the following:

#!/bin/bash
exit 0

2. Change permissions: chmod 755 stat
3. Copy it in /usr/local/bin folder

Then run the installer again and the stat action should not fail. Once the stack was installed you can remove this script.

 
Avatar derekcharles 6 post(s)

Hmmm, it appears BusyBox always uses built-ins over what’s in the path.

The only way I could get a fake “stat” to work was by putting

alias stat=“echo”

in the system-wide profile.

Whilst that works from the command line, the BitNami Redmine installer falls back to the built-in stat and I get the same error

:(

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

OK you replace it the system “stat” comand with a fake script?

 
Avatar derekcharles 6 post(s)

Well, stat is part of BusyBox, so I can’t actually replace that individual command with a fake script.

And having a fake script in my path doesn’t work, because BusyBox will always execute an internal command instead of what is in the path.

And even using an alias to redirect stat doesn’t work (although as I say, this final method DOES work from the command line but not with the installer).

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Sorry in this case it seems it is not possible to run the installer on top of BusyBox.

 
Avatar derekcharles 6 post(s)

That’s a real shame. I think you’d get quite a lot of interest if there was a modified stack suitable for BusyBox as it’s in a LOT of embedded devices, stripped-down systems and NAS boxes!

Forums Redmine