This forum is no longer active. Please post your questions to our new community site

Forums Redmine

Cannot enable Advanced Subversion Integration on ami-0227d96b

Subscribe to Cannot enable Advanced Subversion Integration on ami-0227d96b 10 post(s), 2 voice(s)

 
Avatar johnwarde 6 post(s)

Hi,

I have started up an instance of the Amazon Web Services pre-built AMI “bitnami-redmine-1.1.3-1-linux-ubuntu-10.04-ebs (ami-0227d96b)” and I wanted have Redmine automatically create and manage the Subversion repository and credentials.

I followed the steps on the following Wiki page:
http://wiki.bitnami.com/Applications/BitNami_Re…

After creating a new project and waiting got the Subversion repository to be created I get the following error message when issue a “svn info ”http://77.77.77.77/svn/testproj">http://77.77.77.77/svn/testproj —username myuser —password mypassword" command
svn: Server sent unexpected return value (500 Internal Server Error) in response to OPTIONS request for ‘http://77.77.77.77/svn/testproj’

A valid repository is being created, on AWS VM, this gives me valid repository details:
sudo svn info file:///opt/bitnami/repository/svn/testproj5

These are the actual steps that I used (fake IP/Keys/usernames/passwords substituted)

cd /opt/bitnami
sudo vim apache2/conf/httpd.conf

  1. uncommented next line
    LoadModule dav_svn_module modules/mod_dav_svn.so
  2. added following line
    LoadModule perl_module modules/mod_perl.so
  3. saved apache2/conf/httpd.conf
    sudo cp apps/redmine/extra/svn/Redmine.pm perl/lib/site_perl/5.8.8/i686-linux/Apache/
    sudo mkdir repository
    sudo mkdir repository/svn
    sudo chown root:daemon repository
    sudo chmod 0755 repository
    sudo chmod 0750 repository/svn
    sudo vim apps/redmine/conf/redmine.conf
    Edited the file to look like the file at the bottom of this document
    sudo bash ctlscript.sh restart
    Logged into the Redmine application as Administrator and go to “Settings” → “Repositories” → “Enable WS for repository management”.
    Click on “Generate a key” and save it.
    Add the following line in the crontab. You can edit the crontab using the command “sudo crontab -e”
    */2 * * * * /opt/bitnami/ruby/bin/ruby /opt/bitnami/apps/redmine/extra/svn/reposman.rb —redmine localhost/redmine —svn-dir /opt/bitnami/repository/svn —owner root —group daemon —command=“/opt/bitnami/subversion/bin/svnadmin create —pre-1.6-compatible —fs-type fsfs” —url http://77.77.77.77/svn —key=MYGENERATEDKEY —verbose >> /var/log/reposman.log

Also tried this afterwards from a bitnami redmine forum suggestion:
sudo nano apps/redmine/lib/redmine/scm/adapters/subversion_adapter.rb
Changed ‘SVN_BIN = “svn”’ to ‘SVN_BIN = "svn —config-dir /opt/bitnami/subversion/bin’"

== apps/redmine/conf/redmine.conf ======
ProxyPass /redmine balancer://redminecluster
ProxyPassReverse /redmine balancer://redminecluster

  1. inserted the following line
    ProxyPass /svn !

<Proxy balancer://redminecluster>
BalancerMember http://127.0.0.1:3001/redmine

  1. johnwarde 14/06/2011 – added the following line
    BalancerMember http://127.0.0.1:3001/redmine
  1. commented out the following line
  2. BalancerMember http://127.0.0.1:3002/redmine

PerlLoadModule Apache::Redmine
<Location /svn>
DAV svn
SVNParentPath “/opt/bitnami/repository/svn”
Order deny,allow
Deny from all
Satisfy any

PerlAccessHandler Apache::Authn::Redmine::access_handler PerlAuthenHandler Apache::Authn::Redmine::authen_handler AuthType Basic AuthName “Redmine SVN Repository” #read-only access Require valid-user Allow from localhost
  1. Allow from another-ip
    Satisfy any
  2. write access

    Require valid-user
  1. for mysql
    RedmineDSN “DBI:mysql:database=bitnami_redmine;host=localhost;mysql_socket/opt/bitnami/mysql/tmp/mysql.sock”
RedmineDbUser “bitnami” RedmineDbPass “mypassword” #You can find this value at /installdir/apps/redmine/config/database.yml

=============

Thanks in advance for your help!

John

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

After creating a new project and waiting got the Subversion repository to be created I get the following error message when issue a “svn info ”http://77.77.77.77/svn/testproj">http://77.77.77.77/svn/testproj —username myuser —password mypassword" command
svn: Server sent unexpected return value (500 Internal Server Error) in response to OPTIONS request for ‘http://77.77.77.77/svn/testproj’

Are you trying form the same machine? Maybe it is necessary to open a port in the Ubuntu firewall (and if you want to access to svn from outside, you also have to open a prot in the AWS firewall). You can find more info at http://wiki.bitnami.com/Virtual_Appliances_Quick_Start_Guide#How_to_configure_the_Firewall.3f

 
Avatar johnwarde 6 post(s)

Hi Beltrán,

Yes, I have tried from outside the instance.

I am based in Ireland (IRL), the AWS Instance machine is based in somewhere in the east coast USA ….

Your suggestions …
Added port number 3690 to my Security Group using the Amazon Web Service console.
USA> sudo ufw allow 3690

To demonstrate that it is a valid, working Subversion repository
USA> sudo svn info file:///opt/bitnami/repository/svn/testproj
Path: testproj
URL: file:///opt/bitnami/repository/svn/testproj
Repository Root: file:///opt/bitnami/repository/svn/testproj
Repository UUID: 76abfda8-96cd-11e0-8b4e-c9513e75f183
Revision: 1
Node Kind: directory
Last Changed Author: root
Last Changed Rev: 1
Last Changed Date: 2011-06-14 22:21:31 +0000 (Tue, 14 Jun 2011)

bitnami@ip-10-212-94-187:/opt/bitnami$ sudo svn log file:///opt/bitnami/repository/svn/testproj
-——————————————————————————————————-
r1 | root | 2011-06-14 22:21:31 +0000 (Tue, 14 Jun 2011) | 1 line

Initial import
-——————————————————————————————————-

Outside of the AWS Instance ….
IRL> svn info http://77.77.77.77/svn/testproj5 —username myusername —password mypassword
svn: Server sent unexpected return value (500 Internal Server Error) in response to OPTIONS request for ‘http://77.77.77.77/svn/testproj5’

IRL> svn info svn://77.77.77.77/svn/testproj5 —username myusername —password mypassword
svn: No repository found in ‘svn://77.77.77.77/svn/testproj5’
… this is different now, used to report same error message above.

I am by no means a linux guru, are there any log files that I can look at to give more information?

Thanks again,

John

 
Avatar johnwarde 6 post(s)

Hi,

I’ve made some typos in my last reply … “http://77.77.77.77/svn/testproj5” should read “http://77.77.77.77/svn/testproj”

Thanks,

John

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Could you specify the full path of your repository? http://YOUR_IP/opt/bitnami/repository/svn/testproj You can find more info about how to change the Subversion URL at http://wiki.bitnami.com/Components/Subversion#How_to_configure_the_repository_URL.3f

 
Avatar johnwarde 6 post(s)

Hi,

Here are the direct links for you to try …

svn info http://75.101.148.165/svn/testproj6
svn info svn://75.101.148.165/svn/testproj6

The repository via Redmine is …
http://75.101.148.165/redmine/projects/testproj…

Hope this helps.

Have you tried to reproduce what I’m seeing on the Bitnami AMI that I have used? Was SVN set-up successfully with the steps from the Wiki page?

Thanks,

John

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Yes, we checked the configuration in the AMI. Check the following section in the redmine.conf file and replace it from “localhost” to “all”:


  #read-only access   
  <Limit GET PROPFIND OPTIONS REPORT>
     Require valid-user
     Allow from localhost --> Allow from all
 
Avatar johnwarde 6 post(s)

Hi Beltran,

I have tried your above suggestion, but it has not worked, I still get this error …
svn info http://75.101.148.165/svn/testproj8 —username user —password replaced
svn: Server sent unexpected return value (500 Internal Server Error) in response to OPTIONS request for ‘http://75.101.148.165/svn/testproj8’
(FYI: created new redmine project testproject8)

I tried to get the list of libraries loaded by Apache using the command “apachectl -t -D DUMP_MODULES” and I got the following error
httpd: Syntax error on line 109 of /opt/bitnami/apache2/conf/httpd.conf: Cannot load /opt/bitnami/apache2/modules/mod_dav_svn.so into server: libsvn_repos-1.so.0: cannot open shared object file: No such file or directory
However, I looked at the configuration file (copied in, at the end of this post) and the syntax seems okay and the library file does exist …
ls -l /opt/bitnami/apache2/modules/mod_dav_svn.so
-rwxr-xr-x 1 root root 160648 2011-05-18 14:41 /opt/bitnami/apache2/modules/mod_dav_svn.so
Could the library be corrupt?

Also, there has not been any modification to Subversion configuration files, either per repository or in the /opt/bitnami/subversion/bin/config file, would this be a symptom of the mod_dav_svn.so library loading?

Thanks again for you help,

John

 

Attached Files

 
Avatar johnwarde 6 post(s) … adding to my last post …

When I restart the servers via sudo bash ctlscript.sh restart, it does not complain about the error reported by apachectl -t -D DUMP_MODULES.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

No sorry, you can fix the apachectl issue adding the subversion/lib path in the LD_LIBRARY_PATH in the apache2/bin/envvars file. We will fix this issue for the next release but not sure what could be the problem with Redmine and Subversion. Please check the following guide and maybe you find more help http://opendesignengine.net/projects/ode/wiki/I…

Forums Redmine