This forum is no longer active. Please post your questions to our new community site

Forums Redmine

Configuring Gmail on Windows 2008 server

Subscribe to Configuring Gmail on Windows 2008 server 4 post(s), 2 voice(s)

 
Avatar nivarp 3 post(s)

I have gone through the list of email configuration issues that is listed on this wiki and found them to be very useful. However even after following all the combinations of solutions present I am still not able to set up the email configuration for Redmine.

Platform: Amazon web service instance created using Bitnami public AMI on Windows 2008 server. Redmine 1.2.0

configuration.yml:
production:
delivery_method: :smtp
smtp_settings:
tls: true
enable_starttls_auto: true
address: “smtp.gmail.com”
port: ‘587’
domain: “smtp.gmail.com”
authentication: :plain
user_name: “”mailto:user@gmail.com">user@gmail.com"
password: “password”

config/environment.rb: Changes the following from false to true

config.action_mailer.perform_deliveries = true

Restart from start menu option provided.

Login → Administration → Settings → Email notification and send a test mail

Error received: An error occurred while sending mail (No connection could be made because the target machine actively refused it. – connect(2))

Any suggestion to get this to work? Any changes need to be made on AWS like port forwarding?

Thanks in advance.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Please check that the spaces at the beggining of the line are correct. You should not use quotes.


production:
    delivery_method: :smtp
smtp_settings:
     address: smtp.gmail.com
     port: 587
     domain: gmail.com
     authentication: :login
     user_name: your_email_address
     password: xxxxxx
 
Avatar nivarp 3 post(s)

Hi,

Thanks for the prompt reply. I tried your suggestion, however it did not work. Moreover I believe for gmail we need to use tls.

production:
delivery_method: :smtp
smtp_settings:
tls: true
enable_starttls_auto: true
address: smtp.gmail.com
port: 587
domain: gmail.com
authentication: :plain
user_name: username@gmail.com
password: XXXXXXX

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

You are right, it is necessary to add the tls settings. The authentication option should be “login” instead of “plain”.

Forums Redmine