This forum is no longer active. Please post your questions to our new community site

Forums Redmine

Redmine Adv. SVN Integration + HTTPS & Redirect to Root

Subscribe to Redmine Adv. SVN Integration + HTTPS & Redirect to Root 7 post(s), 3 voice(s)

Avatar qSkills 3 post(s)


First of all thanks for creating the Virtual Appliances and for the very good wiki. Currently I have a problem I can’t figur out. We downloaded the VM (OpenSuse) and made a few adjustments:

- Advanced integration Redmine/Subversion (worked)
- Redirected /redmine to /

Still everything is good.
- we enabled ssl (2nd virtual host…) and redirected all traffic from :80 to :443

=> Advanced integration doesn’t work anymore. If I create a project within Redmine it doesn’t get created in subversion.

Error-Message in reposman.log:
“Unable to connect to ”http://localhost/redmine/sys/“>http://localhost/redmine/sys/: Failed with 302 Found => ”https://localhost//redmine/sys/projects.xml?key=MyKey">https://localhost//redmine/sys/projects.xml?key…"

Can someone give me a hint, where to look? I changed the directory in the crontab but it didn’t help and the key is correct.


Avatar Beltrán Rueda Administrator 3,714 post(s)


It is possible that you have to add allCONNECT directive in your configuration. Take a look at….

Avatar qSkills 3 post(s)

Hi Beltrán,

I followed your advice and added the allowconnect to the virtualhosts and loaded them in Apache 2 but it didn’t help.

We thought it would be an error in the crontab, thus we changed the directory but we still get the same error.
The thing what I don’t understand, is that I can open the file “” (we changed the directory, it was localhost/redmine..) and see all projects in XML-style.

Here is our crontab-statement:
*/2 * * * * /opt/bitnami/ruby/bin/ruby /opt/bitnami/apps/redmine/extra/svn/reposman.rb —redmine —svn-dir /opt/bitnami/repository/svn —owner root —group daemon —command=“/opt/bitnami/subversion/bin/svnadmin create —pre-1.6-compatible —fs-type fsfs” —url —key=key —verbose >> /var/log/reposman.log

And here the redmine.conf:

<VirtualHost *:80>
ServerAdmin sysadmin
ServerAlias redmine
ErrorLog “logs/error.log”
CustomLog “logs/access.log” combined

  1. This passes through remote_user to mongrel
    RewriteEngine On
  2. Redirect non-static requests to cluster
    RewriteCond %{SERVER_PORT} !^443$
    RewriteRule (.*) https://%{HTTP_HOST}/$1 [L]
    AllowCONNECT 80 443 563
ServerAdmin sysadmin ServerName ServerAlias redmine2 ErrorLog “logs/error.log” CustomLog “logs/access.log” combined
  1. This passes through remote_user to mongrel
    RewriteEngine On
    RewriteRule ^/(.*)$ balancer://redminecluster%{REQUEST_URI} [P,QSA,L]
    SSLEngine on
    SSLCertificateFile /opt/bitnami/apache2/conf/server.crt
    SSLCertificateKeyFile /opt/bitnami/apache2/conf/server.key

ProxyPass / balancer://redminecluster
ProxyPassReverse / balancer://redminecluster
ProxyPass /svn !

<Proxy balancer://redminecluster>

PerlLoadModule Apache::Redmine
<Location /svn>
DAV svn
SVNParentPath “/opt/bitnami/repository/svn”
Order deny,allow
Deny from all
Satisfy any

PerlAccessHandler Apache::Authn::Redmine::access_handler PerlAuthenHandler Apache::Authn::Redmine::authen_handler AuthType Basic AuthName “XYZ” #read-only access Require valid-user Allow from all
  1. Allow from another-ip
    Satisfy any
  2. write access

    Require valid-user
  1. for mysql
    RedmineDSN “DBI:mysql:database=bitnami_redmine;host=localhost;mysql_socket=/opt/bitnami/mysql/tmp/mysql.sock”
RedmineDbUser “bitnami” RedmineDbPass “XYZ” #You can find this value at /installdir/apps/redmine/config/database.yml

FYI: I think there is a typo in the 2nd signing step of the howto for creating certificate:….3f

installdir/apache/conf/server.key -days 365 => shouldn’t it be apache2/conf….?

Thanks for the help!


Avatar Beltrán Rueda Administrator 3,714 post(s)

Thanks for reporting it, I fixed the wiki. I’m afraid that i can not help you with this.

Avatar admin-qskills 1 post

Hi Beltrán,

since I made the following crontab entry I receive an other error changed: (IP at URL and the port of subversion after localhost

New Crontab Entry:
*/1 * * * * /opt/bitnami/ruby/bin/ruby /opt/bitnami/apps/redmine/extra/svn/reposman.rb —redmine localhost:3690 —svn-dir /opt/bitnami/repository/svn —owner root —group daemon —command=“/opt/bitnami/subversion/bin/svnadmin create —pre-1.6-compatible —fs-type fsfs” —url —key=ourkey —verbose >> /var/log/reposman.log

Heres the error:

querying Redmine for projects…
Unable to connect to http://localhost:3690/sys/: end of file reached

Maybe you can help us out with this?

Note: wenn I put a / before the localhost ( /localhost)

I just receive this in reposman.log

querying Redmine for projects…

no further error but nothing happens

Avatar qSkills 3 post(s)

Hi Beltrán,

We got it fixed, at least partial. We had to change the crontab entry. I suggest to include this also in the wiki-documentation as this is probably something for everybody:

… /opt/bitnami/apps/redmine/extra/svn/reposman.rb —redmine-host localhost:3001/ —svn-dir …

I hope this helps!


Avatar Beltrán Rueda Administrator 3,714 post(s)

I’m glad to hear this. Thanks for posting the solution, we will add this in the Wiki.

Forums Redmine