This forum is no longer active. Please post your questions to our new community site

Cannot install sqlite3-ruby gem

Subscribe to Cannot install sqlite3-ruby gem 2 post(s), 2 voice(s)

 
Avatar treyster 1 post

Can’t seem install sqlite3-ruby on Ubuntu Jaunty with Rubystack 1.4 Beta 1. I’ve installed build-essential, sqlite3, libsqlite3-0 and libsqlite3-dev, and specified the sqlite dir by:

gem install sqlite3-ruby -- --with-sqlite3-dir=/opt/rubystack-1.4-beta-1/sqlite

I’ve also tried to install the 1.2.3 version of the gem, to no avail.

In each case, the response is:

checking for fdatasync() in -lrt... no checking for sqlite3.h... yes checking for sqlite3_open() in -lsqlite3... no make make: *** No rule to make target `ruby.h', needed by `sqlite3_api_wrap.o'. Stop. Gem files will remain installed in /opt/rubystack-1.4-beta-1/ruby/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.2.4 for inspection. Results logged to /opt/rubystack-1.4-beta-1/ruby/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.2.4/ext/sqlite3_api/gem_make.out

Thanks.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Have you tried to run this command into the rubyconsole?

$ ./rubyconsole
$ gem install sqlite3-ruby——with-sqlite3-dir=/opt/rubystack-1.4-beta-1/sqlite

I have installed successfully:


$ ./rubyconsole
bash-3.2$ gem install sqlite3-ruby -- --with-sqlite3-dir=/home/bitrock/rubystack-1.4-beta-1/sqlite/
Building native extensions.  This could take a while...
Successfully installed sqlite3-ruby-1.2.4
1 gem installed
Installing ri documentation for sqlite3-ruby-1.2.4...
Installing RDoc documentation for sqlite3-ruby-1.2.4...