This forum is no longer active. Please post your questions to our new community site

Error installing RubyStack on Ubuntu 9.04

Subscribe to Error installing RubyStack on Ubuntu 9.04 14 post(s), 2 voice(s)

 
Avatar mpas 9 post(s)

Hi there, when installing RubyStack on a VirtualBox / Ubuntu 9.04 VM i get an error on the last steps ..

‘Unable to create symbolic link /opt/rubystack-1.6-0/git/libexec/git-core/git-rerere → ../../bin/.git.bin’

Any idea how to solve this?

I started the install with:
> sudo bitnami-rubystack-1.6-0-linux-installer.bin

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Are you installing RubyStack on a ntfs partition which does not support symbolic links?

 
Avatar mpas 9 post(s)

I checked in the terminal what filesystem the VBox is using and I guess checking the output of mount command it uses ext3

uadmin@UbuntuVM:/$ mount
/dev/sda1 on / type ext3 (rw,relatime,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,nosuid,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
lrm on /lib/modules/2.6.28-15-generic/volatile type tmpfs (rw,mode=755)
securityfs on /sys/kernel/security type securityfs (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/uadmin/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=uadmin)
/dev/sr0 on /media/cdrom0 type iso9660 (ro,nosuid,nodev,utf8,user=uadmin)

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Strange, is there free space enough in the machine?

 
Avatar mpas 9 post(s)

The df command reports:
/dev/sda1 7850996 3861128 3591056 52% /

So roughly 3.5 GB free should be enough. The error occurs at the end of the install, when all files are copied and then the symbolic links are (not) created.

 
Avatar mpas 9 post(s)

Tried to create symlinks in the terminal and that works ok.. at least the ln -s .. stuff, i do not know what the installer tries to execute exactly.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

could you attach the /tmp/bitrock_installer.log file?

 
Avatar mpas 9 post(s)

As requested

 

Attached Files

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Really strange. Could you type “df -i” command to check the available i-nodes when the Stack installer fails? Could you try to create the link once the installer fails?

 
Avatar mpas 9 post(s)

Attached are the output of the df -i and screenshot of the actual error. Can you please tell me which link i have to create? Then i will surely try it.

 

Attached Files

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

I’m refering to the symbolic link which is failing: /opt/rubystack-1.6-0/git/libexec/git-core/git-rerere → ../../bin/.git.bin

Could you try to run the installer with the “—debugtrace” option and attach the file?

 
Avatar mpas 9 post(s)

The creation of the links gives this output:

  1. ln -s /opt/rubystack-1.6-0/git/libexec/git-core/git-rerere ../../bin/.git.bin
  2. ln: aanmaken van symbolische koppeling `../../bin/.git.bin’: Bestand bestaat al

It gives back the link already exists.. .. going to reinstall now with the -debugtrace

 
Avatar mpas 9 post(s)

Attached the output from the installation with the —debugtrace option. .. Correction, i can’t seem to attach the logfile, size to large? zipped 2,4 MB.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi

You can send us to hello (at) bitnami (dot) org. Thanks.