This forum is no longer active. Please post your questions to our new community site

"gem update rails" not working

Subscribe to "gem update rails" not working 2 post(s), 2 voice(s)

 
Avatar davesailer 1 post

I can’t update rails. My computer eventually uses all RAM and then starts using more and more swap space until it stops responding. I get the same results with either “gem update rails” or “gem update rails—include-dependencies”

I found this out trying to install Radiant CMS a few days ago. I had to download the gem, unpack it, and manually install it, which worked, but I don’t want to depend on that.

Tonight I tried updating Rails to see if I was just having a problem with Radiant. No.

The following shows my input and the system’s response. I get no more output than the fourth line below.

$ cd <intallation_directory>/ruby/bin/
$ ./gem update rails
Updating installed gems…
Bulk updating Gem source index for: http://gems.rubyforge.org

I understand that this can be a problem on some Linux systems when, for some reason, the process tries to read all available gems in the repository into memory before doing an update (or something like that).

Is there something I can do?

Thanks.

2008_10_28: Thanks for the suggestions. I can use all the help I can get. Much appreciated.
—Dave

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

It seems that the RAM usage is a known problem of rubygems. Take a look this forum: http://forum.slicehost.com/comments.php?DiscussionID=672

You can install gems locally. Download the gem from http://gems.rubyforge.org and try to install with:

gem update xxx.gem -l