This forum is no longer active. Please post your questions to our new community site

Great installer, but no luck using RubyStack

Subscribe to Great installer, but no luck using RubyStack 3 post(s), 3 voice(s)

 
Avatar Imran Anwar 1 post

While I am much appreciative for the great effort being put into making these one-click installers of pretty complex infrastructures, I have to say, after more than a month of tinkering, I am disappointed in usability overall.

I have gone through several attempts of installing/uninstalling/reinstalling RubyStack on OSX Tiger, Leopard, again on Tiger on a machine with nothing but Tiger running on it.

1. Making the install so easy is beautiful but there is no info for newbies to easily start the system up after a reboot of the machine
2. The settings for paths do not get set so most commands run at the $ prompt fail with a command not found type error
3. Even supposedly simple things like $ gem install ferret or acts_as_ferret type things run for a while but fail during the install process (even on a machine with nothing but a fresh install of the OS {and all updates}
4. Even simpler things, like running rubyconsole fail (and others have mentioned that on this forum but did not get a straight answer).

So, maybe the people finding RubyStack most usable are also the ones who could have done the install of most of the components themselves. Newbies or light users hoping to find RubyStack a straightforward way to get into the process of using ready-made code from books like RailsSpace are left quite frustrated. Sorry for these comments, appreciate the effort, but have to give this as constructive criticism.

If I am doing something wrong, I’d be happy to be corrected.

Imran

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi Imran,

It is very strange because we have tested the RubyStack on several OS X. I will try to reply your questions:

1. You can find in the README or in the pdf how to start MySQL and Apache after a reboot of the machine. You only should to go to the rubyconsole and type:

$ cd /Applications/rubystack-(version)
$ ./ctlscript.sh start

Also you can find an article to how to install as service to automatically start when you reboot the machine here Besides we are working to create an graphical interface to start/stop the servers easily that we will release soon.

2. I think that you are not running the Stack properly. The Stack install everything in a directory, not directly in your system. If you want to use ruby command or another command you should to type this command into the “rubyconsole”. You can use the “rubyconsole” with a double click in the icon or executing in a terminal:

$ cd /Applications/rubystack-(version)
$ ./rubyconsole

Then you can type any ruby, mysql, subversion, apache, etc command here. The advantage to use Stacks is that they are completely self­-contained and relocatable, so they will not interfere with existing software installations, co­existing side by side with previous versions of Apache, MySQL, and so on that may be already installed in the system. You can uninstall the stack and your system is exactly the same that after to install the Stack.

3. Have you tried to execute this command into the rubyconsole?

$ gem install ferret

We have tried this and we have no problem installing the gem.

4. It is strange, how you are starting the rubyconsole? What is the exact error?

Thanks for your feedback, we are currently working to improve the Stacks and it is very helpful for us the user opinion. I hope it helps :)

 
Avatar Manu 50 post(s)

Hi Imran,

I’m not be able to reproduce your error, but ferret gem needs “make” tool to be installed previously, if you don’t have installed it you won’t be able to install ferret gem.

I have installed acts_as_ferret without problems. Do you have installed compilations tools in your machine?.

Cheers.
Manu.