This forum is no longer active. Please post your questions to our new community site

ImageMagick - NoDecodeDelegate?

Subscribe to ImageMagick - NoDecodeDelegate? 9 post(s), 3 voice(s)

 
Avatar Pete 5 post(s)

Hello-

I just switched from Instant Rails and am trying to get a simple RMagick example to run but am getting the following error:

C:/BITNAM1/ruby/lib/ruby/gems/1.8/gems/rmagick-1.15.9-win32/lib/RMagick.rb:1659:in `read’: NoDecodeDelegateForThisImage
Format `logo.jpg’ (Magick::ImageMagickError) from C:/BITNAM
1/ruby/lib/ruby/gems/1.8/gems/rmagick-1.15.9-win32/lib/RMagick.rb:1659:in `initialize’ from C:/BITNAM1/ruby/lib/ruby/gems/1.8/gems/rmagick-1.15.9-win32/lib/RMagick.rb:1658:in `each’ from C:/BITNAM1/ruby/lib/ruby/gems/1.8/gems/rmagick-1.15.9-win32/lib/RMagick.rb:1658:in `initialize’ from imagePlay.rb:4:in `new’ from imagePlay.rb:4

The example I am trying to run can be found here (example #1):
http://www.imagemagick.org/RMagick/doc/usage.html

Can anyone help me here?

Thanks!

 
Avatar Pete 5 post(s)

So, as a side question to this topic….Do you have to do any configuration to get ImageMagick to work properly?

 
Avatar Pieter 18 post(s)

Hey Pete,

Which version of Rubystack are you using?
The first version did have problems with imagick/rmagick, which were solved in RubyStack 1.0-beta-2.

In case you are using the latest version, could you post the output when executing “set” in command line? (the MAGICK_* related lines should be enough), especially the MAGICK_CODER_MODULE_PATH variable.

Cheers,

Pieter

 
Avatar Pete 5 post(s)

I am using the latest version, below is the output from “set”. See anything wrong here?

MAGICK_CODER_MODULE_PATH=C:\PROGRA1\BITNAM1\imagemagick\modules\coders
Path=C:\BITNAM1\ruby\bin;C:\BITNAM1\mysql\bin;C:\BITNAM1\subversion\bin;C:\BITNAM1\imagemagick;C:\Tcl\bin;C:\Perl\bi
n\;c:\java\jdk1.5.0_12\bin;c:\ruby\bin;C:\Perl\site\bin;C:\Perl\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\W
bem;C:\Program Files\ATI Technologies\ATI Control Panel;C:\Program Files\MATLAB\MATLAB Component Runtime\v74\runtime\win
32;C:\Program Files\QuickTime\QTSystem\;C:\Program Files\MySQL\MySQL Server 5.0\bin
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.RB;.RBW;.tcl
QTJAVA=C:\Program Files\Java\jre1.6.0_03\lib\ext\QTJava.zip
RUBYOPT=rubygems

 
Avatar Manuel 71 post(s)

yes :)

Just edit the file C:\BITNAM~1\scripts\load_path.bat and substitute this:

MAGICK_CODER_MODULE_PATH=C:\PROGRA~1\BITNAM~1\imagemagick\modules\coders

for this:

MAGICK_CODER_MODULE_PATH=C:\BITNAM~1\imagemagick\modules\coders

and everything should work now. We we’ll solve this issue in future releases, thank you for helping us.

 
Avatar Pete 5 post(s)

Thanks.

I thought I could edit this path in the system properties but I don’t see it in there. Where do I update this path?

 
Avatar Pieter 18 post(s)

As Manuel said, the path should be editable via C:\BITNAM~1\scripts\load_path.bat
Close the Ruby console and open it again and it should work.

 
Avatar Pete 5 post(s)

I guess it help for me to read the whole post. :)

That worked, thanks very much!

 
Avatar Pieter 18 post(s)

You’re welcome.
I’m glad it worked!

Ciao