This forum is no longer active. Please post your questions to our new community site

ImageMagick problem

Subscribe to ImageMagick problem 10 post(s), 3 voice(s)

 
Avatar petchia 12 post(s)

I just installed the RubyStack and am excited to see new development on Windows tools for doing Rails development. My application is making use of the Rails simple_captcha plugin which has a dependency on RMagick which ultimately depends on ImageMagick. It looks like the RubyStack is all setup to go for using RMagick and IMageMagick, however when I go to run my application I get an error dialog. Here are the details:

Dialog Title: “ruby.exe – Unable To Locate Component”
Dialog Message: “This application has faied to start because CORE_RL_magick_.dll was not found. Re-installing the application may fix thsi problem.”

Do I need to installe ImageMagick DLLs on my machine or does RubyStack install them. I’m pretty sure the DLLs are required in order to run ImageMagick. Any help is appreciated. In the meantime I’m going to go ahead and install the DLLs and see if that fixes my problem. I will report back with my results.

It would be ideal if we don’t have to specifically install any DLLs. That’s the nice thing with InstantRails, you can just unzip InstantRails in any directory and everything runs. However, InstantRails does not package ImageMagick.

 
Avatar petchia 12 post(s)

Well, I was unable to find a binary for ImageMagick 6.3.5 which comes with RubyStack. The only version available on ImageMagick’s website is ImageMagick 6.3.7.

Ruby is now able to find the DLL I mentioned in my last post, but the DLL doesn’t work. I’m presuming because it is incompatible with the 6.3.5 version of ImageMagick that is packaged with RubyStack.

I will try one more thing. I will try to replace the ImageMagick directory in the RubyStack install directory with the ImageMagick files that come with ImageMagick 6.3.7 that I installed on my machine.

 
Avatar petchia 12 post(s)

Ok, that didn’t work either. Copying the ImageMagick 6.3.7 files into the RubyStack “imagemagick” directory didn’t work.

Any help is greatly appreciated. This RMagick/ImageMagick stuff on windows seems to be a real trouble spot from what I can tell after doing some google searches.

 
Avatar Manuel 71 post(s)

Hi petchia!

RMagick and ImageMagick are bundled with RubyStack and they should work. No extra dll files are needed for ImageMagick as soon as we are using the static version of ImageMagick. I’m working trying to reproduce your problem. Can you please provide us more info about how did the problem appeared. What is the chunk of code that is causing the error message? when does it appear exactly?

 
Avatar antonio 621 post(s)

Hi,

Also, can you tell us if you have an installation of One Click Ruby Installer in your system? We have found an issue with the environment variables, and that could be the problem.

Cheers

 
Avatar petchia 12 post(s)

Sure I can provide you any details you need.

I am specifically trying to use the Ruby on Rails simple_captcha plugin. All it does is call require “RMagick” in the code.

I get the error I mentioned about the DLL issue as soon as I run “ruby script\server” for my Rails application that uses the simple_captcha plugin.

 
Avatar Manuel 71 post(s)

We’ve just released a new version (1.0-beta-2) that solves the RMagick problem. Thank you very much for your help and tell us if the solution worked for you! :)

 
Avatar petchia 12 post(s)

Thank you for the super fast turnaround. I just went to download the 1.0 beta 2 release and all of the links on your site are still pointing to a 1.0 beta 1 file. Are you going to change the link soon?

 
Avatar Manuel 71 post(s)

Maybe it’s your browser cache, try to force reload (usually ctrl+F5).

cheers

 
Avatar petchia 12 post(s)

You da man!!! I downloaded and installed and everything is working so far. ImageMagick is generating the CAPTCHAs.

Rock on!