This forum is no longer active. Please post your questions to our new community site

libcrypto.0.9.8.dylib on Mac problem

Subscribe to libcrypto.0.9.8.dylib on Mac problem 2 post(s), 2 voice(s)

 
Avatar kwahu 1 post

1) Just installed rubystack 2.1-0
2) added xport PATH=$PATH:/Applications/rubystack/ruby/bin:/Applications/rubystack/git/bin
3) I’m typing rails appname and I got this:
/Applications/rubystack/ruby/lib/ruby/1.8/i686-darwin8.5.3/digest/md5.bundle: dlopen(/Applications/rubystack/ruby/lib/ruby/1.8/i686-darwin8.5.3/digest/md5.bundle, 9): Library not loaded: /bitnami/rubystack-osx-x86/output/common/lib/libcrypto.0.9.8.dylib (LoadError)
Referenced from: /Applications/rubystack/ruby/lib/ruby/1.8/i686-darwin8.5.3/digest/md5.bundle
Reason: image not found – /Applications/rubystack/ruby/lib/ruby/1.8/i686-darwin8.5.3/digest/md5.bundle
from /Applications/rubystack/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require’
from /Applications/rubystack/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in `require’
from /Applications/rubystack/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:521:in `new_constants_in’
from /Applications/rubystack/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in `require’
from /Applications/rubystack/ruby/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails_generator/generators/applications/app/app_generator.rb:3
from /Applications/rubystack/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require’
from /Applications/rubystack/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require’
from /Applications/rubystack/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in `require’
from /Applications/rubystack/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:521:in `new_constants_in’
from /Applications/rubystack/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in `require’
from /Applications/rubystack/ruby/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails_generator/spec.rb:17:in `klass’
from /Applications/rubystack/ruby/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails_generator/lookup.rb:140:in `instance’
from /Applications/rubystack/ruby/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails_generator/scripts/../scripts.rb:31:in `run’
from /Applications/rubystack/ruby/lib/ruby/gems/1.8/gems/rails-2.3.8/bin/rails:19
from /Applications/rubystack/ruby/bin/rails:19:in `load’
from /Applications/rubystack/ruby/bin/rails:19

I’ve already update XCode to 3.14 (the newest one for OSX 10.5)
Updated the openssl through macports but nothing helps.

Any idea?

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

It is necessary to load more environment variables. Try the following:

$ cd /Applications/rubystack-2.1-0
$ ./rubyconsole
$ rails sample

You can find the environment variables at /Applications/rubystack-2.1-0/scripts/setenv.sh

I hope it helps