This forum is no longer active. Please post your questions to our new community site

MacX86 install error- RubyStack 1.4-beta-0

Subscribe to MacX86 install error- RubyStack 1.4-beta-0 11 post(s), 5 voice(s)

Avatar mikele 13 post(s)

tried to install the latest rubystack, but get this error:

When I try to run it, here’s the response:

ganimede:/Applications/rubystack-1.4-beta-0$ ./rubyconsole 
bash-3.2$ pwd
bash-3.2$ irb
/Applications/rubystack-1.4-beta-0/ruby/lib/ruby/1.8/thread.rb:5:in `require': no such file to load -- (LoadError)
    from /Applications/rubystack-1.4-beta-0/ruby/lib/ruby/1.8/thread.rb:5
    from /Applications/rubystack-1.4-beta-0/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:10:in `require'
    from /Applications/rubystack-1.4-beta-0/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:10
    from /Applications/rubystack-1.4-beta-0/ruby/lib/ruby/site_ruby/1.8/ubygems.rb:10:in `require'
    from /Applications/rubystack-1.4-beta-0/ruby/lib/ruby/site_ruby/1.8/ubygems.rb:10

any hint?

Avatar mikele 13 post(s)

Strangely enough – I get the same error when installing the previous rubystack (1.2).

Also the console reports the same exception.. I’m starting thinking that there’s something in my system causing the problem – I wonder how, given that rubystack is a completely separate installation..

any suggestion much appreciated!! thanks in advance..

Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi mikele,

Thanks for reporting the error. We are trying to reproduce it. Could you reproduce this error in another OS X machine?

Avatar mikele 13 post(s)

Sorry I can’t ! The other mac I have is a powerPc … here instead I’m running 10.5.5.
I thought it was related to a mysql instance that was running in the background, so I stopped it (and actually deleted the mysql standalone mysql installation), re-installed rubystack 1.4, but the problem persisted!!!!!
i’m kinda stuck here cause I need a ruby develop environment..:-( trying to go back to a non-stacked solution now

Avatar Henry Cavill... 1 post

Im having exact same problem. I thought it might have something to do with XCode Tools having to be installed so I re-installed those but same problem occurs

Avatar Beltrán Rueda Administrator 3,714 post(s)

Thanks, we can reproduce it and we will fix the bug as soos as possible, thanks for reporting it.

Avatar mikele 13 post(s)

Sounds great – rubystack is really neat!
BTW I tried also to install JRUBYstack, but had no luck here too
It hangs while trying to install rails – from the activity monitor it looks like it’s java that is going nuts, sucking 99% of the cpu.

Avatar Daniel Lopez Administrator 140 post(s)


We have found the issue, it was a problem in our build scripts. We will be publishing a new stack asap, if possible today or tomorrow.

Avatar Manu 50 post(s)

Hi all,

Just a quick note to let you know that a new RubyStack is available in BitNami. This new version includes the OS X fix.

Enjoy it!.


Avatar mikele 13 post(s)

Hi all,

thanks very much indeed!! just installed it – works perfectly!