This forum is no longer active. Please post your questions to our new community site

moving radiant from subdir to root

Subscribe to moving radiant from subdir to root 5 post(s), 2 voice(s)

 
Avatar jandaltech 3 post(s)

Hi.

Apologies if this has already been covered, my searches haven’t gone well. I’ve tried modifying and following the advice in https://bitnami.com/forums/forums/redmine/topics…, but can’t get what I’m after.

I have rubystack installed on Slackware 13.0, with the radiantCMS module, which is working happily at www.jandaltech.com/radiant, but I would like to have it at just www.jandaltech.com.

Is there a simple answer to this question?

I’ve been playing around with configuration files and restarts for hours, and have had a small degree of success modifying mongrel_cluster.yml to lose the prefix=/radiant, and modifying apps/radiant/conf/radiant.conf, but I can only get the content to display on www.jandaltech.com, no css or formatting with it.

Appreciate any pointers.

Cheers,

Chris

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

This post could be helpful for you. The Apache configuration is be the same for Linux and Windows https://bitnami.com/forums/forums/redmine/topics…

Cheers.

 
Avatar jandaltech 3 post(s)

No joy.

I have taken prefix: /radiant line out of apps/radiant/config/mongrel_cluster.yml.

My apps/radiant/conf/radiant.conf is as follows:


<VirtualHost *:80>
        RewriteEngine On
        RewriteCond %{DOCUMENT_ROOT}/%{REQUEST_FILENAME} !-f
        RewriteRule ^/(.*)$ balancer://radiantcluster%{REQUEST_URI} [P,QSA,L]
</VirtualHost>
ProxyPass / balancer://radiantcluster
ProxyPassReverse / balancer://radiantcluster
<Proxy balancer://radiantcluster>
  BalancerMember http:// 127.0.0.1:3001
</Proxy>

(without the space in http:// 127.0.0.1:3001)

Now my radiant appears in the root at www.jandaltech.com, but without any css formatting. Any ideas? The poster in the other thread seemed to have this issue also, but I can’t see how he resolved it. I have tried both with the ProxyPass lines as posted, and commented out, as was shown in another solution, but both produce the same result.

Thankyou very much,

Chris

 
Avatar jandaltech 3 post(s)

Sorted!

Edited the normal layout from jandaltech.com/admin to match the radiantCMS demo site, and it fixed everything. At the next hurdle, writing my own, but happily convinced the issue is now not with my bitnami config.

Thanks again

Chris

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

I’m glad to hear this