This forum is no longer active. Please post your questions to our new community site

MySQL Service Bug

Subscribe to MySQL Service Bug 5 post(s), 3 voice(s)

 
Avatar timw06 3 post(s)

When I run the start menu item to start mySQL nothing happens and when I went to “services.msc” there isn’t anything remotely resembling a “RubyStack MySQL” service to start. The installer worked fine and as far as I can see everything is in the mysql/bin folder on my drive but there is no service and so I can’t start the server. Help! PS: I’m running Vista Premium Thanks!

 
Avatar Manuel 71 post(s)

Hi timw06, thank you for posting the bug. First of all, what happen when you try to connect to the database? Open a “Use Ruby” console and try to run following command:

mysql -u root -p—port=3306

What error message do you get?

If none, MySQL is running. Then you can try to start your web server as described in https://bitnami.com/tutorials/from_instantrails_to_rubystack in the section “How can I start my web application?”

regards

 
Avatar timw06 3 post(s)

ERROR 2003 (HY000): Can’t connect to MySQL server on ‘localhost’ (10061)

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

This error happens when MySQL server is not started. You can try to start MySQL server manually. Open a “Use Ruby” console and type this command:

mysqld

Then, you can try to connect to mysql. Open another ruby console and run the following command:

mysql -u root -p

If no error is found, you can see the MySQL welcome message.

 
Avatar timw06 3 post(s)

thanks beltran it’s working now