This forum is no longer active. Please post your questions to our new community site

Nokogiri incompatible with RubyStack 2.0.3

Subscribe to Nokogiri incompatible with RubyStack 2.0.3 2 post(s), 2 voice(s)

Avatar julian 6 post(s)

bash-3.2$ which nokogiri
bash-3.2$ nokogiri
WARNING: Nokogiri was built against LibXML version 2.7.6, but has dynamically loaded 2.7.2
Nokogiri: an HTML, XML, SAX, and Reader parser
Usage: nokogiri <uri|path> [options]

nokogiri ./public/index.html

—type [TYPE]
-?, —help Show this message
-v, —version Show version

Any idea what to do? I really like the idea of bitnami but this the second time I’ve had serious problems out of the box which have taken me hours to try and find. I don’t know whether its the source of a more problematic issue but I’m getting

/Applications/Rails/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/core_ext/kernel/agnostics.rb:7: [BUG] Segmentation fault
ruby 1.8.7 (2009-12-24 patchlevel 248) [i686-darwin8.10.2], MBARI 0×8770, Ruby Enterprise Edition 2010.01

on any attempt to install gems as well. Doesn’t happen in a freshly made Rails app so I have to assume its the nokogiri issue?

Avatar Beltrán Rueda Administrator 3,714 post(s)


The nokogiri issue seems only a warning that we will try to fix for the next version. The segmentation fault issue is a Ruby Enterprise issue. This seems a random issue that we could reproduce from time to time. We will investigate the root of this issue but maybe we will include only Standard Ruby on OS X instead of Ruby Enterprise.