This forum is no longer active. Please post your questions to our new community site

Noob having issues Ubuntu 9.04

Subscribe to Noob having issues Ubuntu 9.04 6 post(s), 3 voice(s)

 
Avatar kevins 7 post(s)

I downloaded the installer.bin to the /Desktop.

Right clicked and set the “Allow executing file as a program”.

kevin@computer:~$ sudo ~/Desktop/bitnami-rubystack-1.6-0.linux-installer.bin

“No such file or directory.”

I’ve tried every path ./ ~ combo I can from /Desktop, /Documents, and no luck. I know it’s spelled correctly, capitalization as well. Any ideas?

Thank you very much.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Could you check if the installer is there?

$ cd ~/Desktop
$ ls

You should see the installer in this folder. In other case the installer it does not in the Desktop folder. Change the permissions and run it:

$ chmod 755 bitnami-rubystack-1.6-0.linux-installer.bin
$ ./bitnami-rubystack-1.6-0.linux-installer.bin

Another option is:
- Rename the file and remove the .bin extension
- Right click in the file → Permissions → Allow executing file as program
- Double click in the file

I hope it helps.

 
Avatar kevins 7 post(s)

The installer is there. I have tried everything, chmod, renaming, double clicking, right click set permission, right click “open”, downloaded another copy, etc.. I know enough to LS and see the file and I know enough about linux to set permissions. It doesn’t seem to work for some reason. I’m beginning to think this is something to do with the ubuntu 9.04 default distro but I am out of ideas and not really enjoying the whole experience :)

I have also observed from System Monitor that absolutely nothing happens, no processes are launched, etc., when I execute the file.

 
Avatar kevins 7 post(s)

Also a thread I started on Ubuntu community forums.

http://ubuntuforums.org/showthread.php?p=8068987

In summary, I’ve done everything asked from +x to 755 to rename and open move file etc.

I can’t get any .bin files from anywhere to execute.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Is it possible that your system is an Ubuntu 64-bits? In this case you need the compat libraries to run 32 bits binary files. You can check if your system is a 64 bits system running the following command:

$ uname -a

And you can see something like “i686 GNU/Linux” if it is a 32 bits system or " x86_64 GNU/Linux" if it is a 64 bits system. In this case you need the compat libraries, that you can install in Ubuntu typing the following:

sudo apt-get install ia32-libs

Then try to run theBitNami Stack.

Cheers.

 
Avatar mpas 9 post(s)

I am also installing it on Ubuntu.

The install fails at the end when using Ubuntu on a VM using Virtual Box but on my normal machine it did go perfect. Downloaded the installer, chmod +x and after that installed it with sudo ./bitnami-rubystack-1.6-0.linux-installer.bin