This forum is no longer active. Please post your questions to our new community site

OSX problem

Subscribe to OSX problem 4 post(s), 2 voice(s)

 
Avatar Aktion 17 post(s)

Hello, i’v installed RubyStack to OSX Tiger 10.4.11 PPC, everything is fine but when Im trying to execute script/server i got this error message:
“Rails requires RubyGems >= 0.9.4. Please install RubyGems and try again: http://rubygems.rubyforge.org

Funny but using Windows version, i got redmine installed and running perfectly.

Please advice.

About your application’s environment
Ruby version 1.8.6 (powerpc-darwin8.4.0)
RubyGems version 0.9.4
Rails version 2.0.2
Active Record version 2.0.2
Action Pack version 2.0.2
Active Resource version 2.0.2
Action Mailer version 2.0.2
Active Support version 2.0.2
Application root /Applications/rubystack-1.0/projects/cookoff
Environment development
Database adapter mysql

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi Aktion,

Thanks for report this issue. We have some questions to find the error. To set the RubyStack environment variables you have to execute first the rubyconsole:

$ ./rubyconsole

Are you executing “script/server” into the rubyconsole? We included RubyGems 0.9.4, have you installed another “ruby on rails” software in your OS X which includes another RubyGem version?

Thanks.

 
Avatar Aktion 17 post(s)

Are you executing “script/server” into the rubyconsole?

nope, executing this in terminal actually. Ill try do it tonight at OSX

We included RubyGems 0.9.4, have you installed another “ruby on rails” software in your OS X which includes another RubyGem version?
Nope, i’v only installed RubyStack and thats it.

I suspect maybe I didn’t terminated previous session – localhost:3000 executes default rails session.

 
Avatar Aktion 17 post(s)

Yeah, w/ rubyconsole working, thanks!
Now lets try to recreate rubyonrails tutorial video