This forum is no longer active. Please post your questions to our new community site

Problem installing under Linux

Subscribe to Problem installing under Linux 6 post(s), 4 voice(s)

 
Avatar crowja 4 post(s)

I’m running into a weird problem with a Linux install.

$ uname -a
Linux matlock 2.6.18-xen #1 SMP Tue Feb 12 06:40:50 UTC 2008 x86_64 GNU/Linux

$ ./bitnami-rubystack-1.2-1-linux-installer.bin—mode text
$

That’s it … Instant return, no log files locally or in /tmp, no installation of the stack. Any idea what might be up? For what it’s worth, same thing happens with 1.4-beta-1. Any guidance is appreciated!

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Currently the installers only supports x86 platforms (not x86_64). If you want to run the installer in this platform you should install the compatibility libraries. On Red Hat systems (CentOS, Fedora, ...) you can install using “yum install compat-libstdc++”. On Debian systems (Ubuntu and others) you should run “sudo apt-get install” for several libraries:

ia32-libs_1.19_amd64.deb
lib32gcc1_4.2-20070609-1_amd64.deb
lib32stdc++6_4.2-20070609-1_amd64.deb
libc6-i386_2.5-9_amd64.deb

Cheers.

 
Avatar julian 6 post(s)

Does the ‘32 bit only’ restriction also apply to Windows? If I would like to install Bitnami on Windows Vista / 64 do you have suggestions as to what to do?
thanks!

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi Julian,

On Windows is different, you can install 32-bits application without any problem. Let me a suggestion, a bitnami user have installed Redmine recently on Windows Server 8 64 bits and he has got an error starting MySQL database. Take a look this post So I suggest you to use a installation directory without white spaces, for example C:\my_stack. We are working to reproduce and fix the issue.

Cheers

 
Avatar Alain Béarez 3 post(s)

Hi,

I could not install the RubyStack 1.5-2 on Linux (x86) nor with the default ports given by the wizard nor with custom ports… It always ends up giving the following error in a popup window:
-————————————
Error running /opt/rubystack/mysql/scripts/myscript.sh
/opt/rubystack/mysql 4ub75tack : ERROR: 1062 Duplicate entry
‘localhost-’ for key 1
090713 20:39:08 [ERROR] Aborting

090713 20:39:08 [Note] /opt/rubystack/mysql/bin/mysqld.bin: Shutdown complete

ERROR 1045 (28000): Access denied for user ’root’@’localhost’ (using password: NO)
ERROR 1045 (28000): Access denied for user ’root’@’localhost’ (using password: NO)
ERROR 1045 (28000): Access denied for user ’root’@’localhost’ (using password: NO)
-————————————

though you can see I gave ‘4ub75tack’ as password… When clicking on the only “OK” button in that window it runs a bit further up to the next popup:
-————————————
Problem running post-install step. Installation may not complete correctly
Error running /opt/rubystack/mysql/bin/mysql u root -e “CREATE
DATABASE IF NOT EXISTS rb_production; CREATE DATABASE IF NOT EXISTS
rb_development; CREATE DATABASE IF NOT EXISTS rb_test; GRANT ALL
PRIVILEGES on rb_test.* to ’rubystack’@’localhost’ identified by
‘4ub75tack’; GRANT ALL PRIVILEGES on rb_production.* to
’rubystack’@’localhost’; GRANT ALL PRIVILEGES on rb_development.* to
’rubystack’@’localhost’; flush privileges;”
—socket=/opt/rubystack/mysql/tmp/mysql.sock -p4ub75tack : ERROR 1045
(28000): Access denied for user ’root’@’localhost’ (using password: YES)
-
————————————-

where the same password shows up again in the command line.

I did not notice any trouble when installing on Windows Vista at my work.

What am I missing?

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

This is a known error of MySQL 5.0.51 version. Take a look this bug We have updated the MySQL version but we have not released yet. The workaround is to modify the machine hostname. Could you modify the machine hostname and reinstall it?

Cheers.