This forum is no longer active. Please post your questions to our new community site

Problem upgrading RubyGems to 1.3.1

Subscribe to Problem upgrading RubyGems to 1.3.1 3 post(s), 2 voice(s)

Avatar james_mcgrath 3 post(s)

Hi All, quick call out to see if anyone has a solution to a little problem that I am having no luck with on RubyStack 1.2.1 on Mac Leopard. I am trying to upgrade my RubyGems to 1.3.1 because I am being told the following:

rails requires RubyGems >= 1.3.1 (you have 1.2.0). Please `gem update—system` and try again.

From this site ( I learnt that gem update has a bug and instead I needed to install a “rubygems-update” gem to get around this bug. This gem installed fine, but when I run the command:

ruby -S update_rubygems

I get no joy, just a message saying “Installing RubyGems 1.3.1” and the system will happily sit there forever. Anyone have this problem before. Anyone know the trick to solve it? I am sure it is so simple it is driving me nuts!

BTW: I have ruby 1.8.6 (2007-03-13 patchlevel 0) [i686-darwin8.5.3]


Avatar carlos Administrator 144 post(s)


I think this is related with this topic:

Can you check commenting out the lines about “RUBYOPT” as it is described there ?


Avatar james_mcgrath 3 post(s)

Carlos you are a champ! And I am a chump! After all the googling I did I forgot to stick “update_rubygems” into this forums search box.

Anyway it seems that after commenting out those RUBYOPT lines in the upgrade process worked. Time to get on with what I was doing!

Thanks again, really appreciate it.