This forum is no longer active. Please post your questions to our new community site

Problem with Capistrano on Windows RubyStack

Subscribe to Problem with Capistrano on Windows RubyStack 5 post(s), 2 voice(s)

 
Avatar ratnik 6 post(s)

Hello,

I work with RubyStack on Windows XP and want to deploy my rails application from Windows machine to the vmware virtual machine with RubyStack. I installed Capistrano and executed the following tasks:

- capify .
- cap deploy:setup
- cap deploy:check

These tasks completed successfully, but when I run

- cap deploy

or

- cap deploy:update

Capistrano shows error: “executable ‘git’ not present or not in $PATH on the local system!”. But my Path variable includes the path to BitNami git and I can push and pull my source to/from RubyStack virtual machine without any problems. I also tried to set :local_scm_command variable in deploy.rb but without success.

Please help to solve this problem.
-
Thank you in advance.

 
Avatar danoo Administrator 81 post(s)

Hi Ratnik,

I have no experience with Capistrano on Windows but the following git commit may be related:

http://github.com/capistrano/capistrano/commit/…

As you can see, they use Unix command which to check if the specific executable is available or not. Do you think it may be an issue in your case ? Do you use Cygwin or similar Unix-like environment on Windows ?

Best regards,
Danoo

 
Avatar ratnik 6 post(s)

Thank you for your reply!

I have removed “command_present?(cmd)” call from the
“capistrano\recipes\deploy.rb” file and my command
“cap deploy” executed successfully! The problem has
been solved!

I hope Capistrano developers will fix this bug in the
next version.

I do not use any Cygwin or similar Unix-like environment
on my Windows XP. Just RubyStack and RubyMine IDE.

My Capistrano version is 2.5.9.

 
Avatar danoo Administrator 81 post(s)

Hi,

I am glad it works for you.

btw. I have sent a simple patch to Capistrano maintainers, they have already committed this change.

http://github.com/capistrano/capistrano/commit/…

Would it be possible for you to build Capistrano gem and test if it works on your side ?

Thanks
Danoo

 
Avatar ratnik 6 post(s)

Perfect! Thanks again, Danoo!

This patch worked for me. When I execute “cap deploy”
for my project, I get the following output:

[…]
executing locally: "git ls-remote ssh://root@192.168.1.2/root/projects/test master"
checking for git… yes
[…]

The bug has been closed!