This forum is no longer active. Please post your questions to our new community site

Problems intalling it in Linux

Subscribe to Problems intalling it in Linux 20 post(s), 3 voice(s)

 
Avatar hackaton 14 post(s)

Debian etch :

Unable to create symbolic link /opt/rubystack-1.1-0/apache2/lib/libapr-1.so ->
libapr-1.so.0.2.12

Tried installing as root and normal user.

Fedora (selinux is disabled)

https://bitnami.com/forums/forums/20/topics/259

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Is this the exact error? Could you check the disk memory and ram memory? Could you send us the log file created in /tmp/bitrock*.log to try to determine the exact error? My email is beltran at bitnami dot org.

Thanks.

 
Avatar hackaton 14 post(s)

i have enough gbs of disk space. where are the log files ? i could not find them in /tmp

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

If you have rebooted the machine the log file has been removed. If you try to install the Stack it should create a log file in your /tmp folder.

 
Avatar hackaton 14 post(s)

didnt find any log files there…

email sent..

 
Avatar hackaton 14 post(s)

This is an automatically generated Delivery Status Notification

Delivery to the following recipient failed permanently:

beltran at  bitnami.com

Technical details of permanent failure:
PERM_FAILURE: Message rejected. See http://mail.google.com/support/bin/answer.py?answer=69585 for more information.

--- Original message ---
 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

It seems that the email server does not let you send me an email. Have you checked the email address? It seems that you have not replaced the “at” with ”@”.

Cheers.

 
Avatar hackaton 14 post(s)

comeon…i also changed it to avoid spam. btw, I am using gmail.com

Do you want to continue? [Y/n]:

--------------
Please wait while Setup installs BitNami RubyStack on your computer.

Installing
0% ___ 50% ___ 100%
############################
Error: There has been an error.
Unable to create symbolic link /opt/rubystack-1.1-0/apache2/lib/libapr-1.so ->
libapr-1.so.0.2.12
Press [Enter] to continue :
 
Avatar hackaton 14 post(s)

Installing
0% ___ 50% ___ 100% ############################

Its throws that error around 65-70% done.

 
Avatar hackaton 14 post(s)

the # and _ are not coming correctly on this board

its around say 65-70% done.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi hackaton,

We can not reproduce the issue. It should be a log file in the /tmp directory called bitrock*.log. It is very helpful for us to try to find the problem. Are you installing the Stack in a hosting? Some of them restrict some commands, for example symbolic links.

Thanks.

 
Avatar hackaton 14 post(s)

its my home machine. which distro are you using ?

 
Avatar hackaton 14 post(s)

is the installer script open source for linux ? I might try running it manually or is it possible to run it in debug mode to see where the problem is occuring ?

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

We have installed it in a Debian Etch 4.0RC3 distribution successfully. You can try to install the Stack in debug mode:

$ ./bitnami-rubystack-(version)-linux-installer.bin – - debugtrace debugfile.log

If it is possible, send us the file to investigate the cause of this error. Thanks.

 
Avatar hackaton 14 post(s)

Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/man/man1/spkac.1
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/man/man1/ec.1
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/man/man1/enc.1
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/man/man1/smime.1
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/man/man1/CA.pl.1
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/man/man1/ecparam.1
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/man/man1/s_client.1
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/man/man1/dsaparam.1
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/man/man1/pkcs8.1
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/man/man1/errstr.1
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/man/man1/rsautl.1
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/man/man1/x509.1
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/man/man1/gendsa.1
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/man/man1/s_server.1
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/man/man1/req.1
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/man/man1/crl.1
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/man/man1/ca.1
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/man/man1/s_time.1
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/openssl.cnf
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/private/NOTEMPTY
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/misc/CA.pl
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/misc/c_info
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/misc/c_issuer
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/misc/c_name
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/misc/c_hash
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/misc/CA.sh
Unpacking /home/my/rubystack-1.2-beta-0/common/openssl/certs/NOTEMPTY
Creating link /home/my/rubystack-1.2-beta-0/common/lib/libiconv.so

I downloaded the beta and tried that…still no sucess. but atleast i got the log file.

 
Avatar hackaton 14 post(s)

Unpacking /home/my/rubystack-1.1-0/common/share/doc/ImageMagick-6.3.6/www/magick.css
Unpacking /home/my/rubystack-1.1-0/common/share/doc/ImageMagick-6.3.6/www/contact.html
Unpacking /home/my/rubystack-1.1-0/common/share/doc/ImageMagick-6.3.6/www/history.html
Unpacking /home/my/rubystack-1.1-0/common/share/doc/ImageMagick-6.3.6/www/perl-magick.html
Unpacking /home/my/rubystack-1.1-0/common/share/doc/ImageMagick-6.3.6/www/mailing-list.html
Unpacking /home/my/rubystack-1.1-0/common/share/doc/ImageMagick-6.3.6/www/download.html
Unpacking /home/my/rubystack-1.1-0/common/share/doc/ImageMagick-6.3.6/www/magick-wand.html
Unpacking /home/my/rubystack-1.1-0/common/share/doc/ImageMagick-6.3.6/www/formats.html
Unpacking /home/my/rubystack-1.1-0/common/share/doc/ImageMagick-6.3.6/www/binary-releases.html
Unpacking /home/my/rubystack-1.1-0/common/share/doc/ImageMagick-6.3.6/www/animate.html
Unpacking /home/my/rubystack-1.1-0/common/share/doc/ImageMagick-6.3.6/www/high-dynamic-range.html
Unpacking /home/my/rubystack-1.1-0/common/share/doc/ImageMagick-6.3.6/www/license.html
Unpacking /home/my/rubystack-1.1-0/common/share/doc/ImageMagick-6.3.6/www/command-line-processing.html
Unpacking /home/my/rubystack-1.1-0/common/share/doc/ImageMagick-6.3.6/www/sitemap.html
Unpacking /home/my/rubystack-1.1-0/common/share/doc/ImageMagick-6.3.6/www/motion-picture.html
Unpacking /home/my/rubystack-1.1-0/common/share/doc/ImageMagick-6.3.6/www/search.html
Unpacking /home/my/rubystack-1.1-0/common/share/doc/ImageMagick-6.3.6/index.html
Creating link /home/my/rubystack-1.1-0/common/lib/libWand.so.10

I have 256MB RAM. This time I tried it from console (turned off gdm, etc.)

 
Avatar Manu 50 post(s)

Hi,

Maybe your problem is the low ram memory… Do you have a swap partition in your hard disk?.

Do you have always the same problem? or Do you have a new problem each time you try to install rubystack?

This log lines are at the same or differents installation proccess?

Cheers,
Manu.

 
Avatar hackaton 14 post(s)

I got the libapr error when I was installing it from terminal in gnome (debian etch) and the libWand error when I did it from command line (X was off)

I have 600 MB of swap so no problems with that.

 
Avatar hackaton 14 post(s)

Cool got it installed finally !!!

It was becoz of the damm swap. It was not acivated. I manully activated it and then the installation worked flawlessly !!

Thanks bitnami for all this. I am going to recommend your products to a lot of people.

 
Avatar Manu 50 post(s)

Hi!,

We are glad to help you!.

Best regards,
Manu.