This forum is no longer active. Please post your questions to our new community site

RadRails and Rmagick - RMagick.so module not found

Subscribe to RadRails and Rmagick - RMagick.so module not found 6 post(s), 3 voice(s)

 
Avatar Silas 4 post(s)

I am running RubyStack 1.0 on Windows. I want to run a server through the eclipse-based RadRails (so I can use the ruby-debug-ide, to get visual debugging).

My project uses RMagick. I have configured RadRails/Aptana to use RubyStack’s Ruby VM, and RubyStack’s Rails.

When I start a server and fetch an action that works from within the UseRuby environment I get the following error:

“The specified module could not be found. – C:/RubyStack/ruby/lib/ruby/gems/1.8/gems/rmagick-1.15.9-win32/ext/RMagick.so”

The module does exist, and is in that folder. I think this is a PATH issue, but I have tried the following with no avail:

- Adding C:/RubyStack/ruby/lib/ruby/gems/1.8/gems/rmagick-1.15.9-win32/ext/ to my windows PATH environment variable.
- Adding C:\RubyStack/imagemagick (which appears in the use_ruby.bat PATH) to my windows PATH.

Any suggestions much appreciated

 
Avatar Manuel 71 post(s)

Hi Silas,

We haven’t tested RubyStack integration with RadRails yet, we we’ll look deeper into this issue. Meanwhile I’d suggest you to try launching RadRails from within an use_ruby console. That should solve any PATH issues. Let us know if it works.

regards

 
Avatar Silas 4 post(s)

Your cunning suggestion did indeed work, thanks!

Looking at setenv.bat there doesn’t seem to be much other than PATH being prepended, but I notice th MAGICK_CODER_MODULE_PATH variable is also set, I will play with this and report back.

What is the meaning of the forward slashes used for the various paths, such as C:\RubyStack/imagemagick ?

 
Avatar Manuel 71 post(s)

Glad to hear that it worked.

About the forward slashes, some code of our installers are the same for Linux, Mac, Solaris and Windows and sometimes, an Unix forward slash appears on a Windows path. As long as Windows cope well with both there is no reason to worry about.

cheers

 
Avatar ror_newbie 1 post

This topic caught my attention because I too am trying to configure Aptana (which claims to have RadRails) to use with the RubyStack (which someone told me is better than InstantRails) on Windows XP.

Please excuse my silly notions (if something is “better” than another tool), but I originally wanted to use Visual Studio 2008 with any kind of good IDE for Ruby on Rails. The only tool for VS2008 that I know of is Ruby in Steel, but it’s expensive, not free.

One guy told me to just stick with a simple text editor like Notepad++ or a bunch of other free ones, but these don’t always have the best highlighting or syntax colors, which may not be such a big deal…

What I would like is a decent IDE that helps me with filling in the rest of common code, hopefully making my life a little easier.

Rather than manually install Ruby and Rails via the method described at http://www.rubyonrails.org/down
I would rather install RubyStack and configure Aptana to correctly access the environment.

I’ve been googling for solutions, but this topic is the ONLY thing I could find that was remotely relevant. I’m sorry if this is the wrong place to post a question.

So…how can I configure Aptana Community edition to play nice with Bitnami’s RubyStack so I can take advantage of the Radrails plugin? I don’t need the paid Pro version do I?

If there’s simpler tools out there for a VERY early beginner like me….please point that out too!

 
Avatar Silas 4 post(s)

Aptana RadRails is very good (eclipse is good), I like it a lot. Particularly with ViPlugin, which (for a cost) gives you a useful subset of the features of the monolitic Vim text editor http://www.satokar.com/viplugin/index.php

I have encountered people who espouse text-editor-only development. I mostly find that this is down to a misguided sense of anti-tool machoism. The slight disadvantage of starting with an IDE is that it may obscure what is actually going on, and encourage dependence on a graphical interface when the underlying command line is actually more elegant. But when you consider the refactoring, debugging, and error flagging abilities of Aptana you see it is so much more productive to use an IDE.

Anyway, I have posted a howto style topic on this (as a separate thread in case others are interested): https://bitnami.com/forums/forums/20/topics/249

Manuel: setting the MAGICK_CODER_MODULE_PATH variable sorted my issues.