This forum is no longer active. Please post your questions to our new community site

rubystack imagemagick no decode delegate

Subscribe to rubystack imagemagick no decode delegate 6 post(s), 4 voice(s)

 
Avatar ganesh.k 2 post(s)

I have installed the latest version of rubystack(2.0.1) when i’m trying to process the image using rmagick i got the “No decode delegate issue”,i have corrected the path in the setenv.sh and also added the environment sample in the application with proper path but negative.
How should i fix this issue ?Any help..

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Sorry, this is a know issue that we will fix for the next release. We will try to release it tomorrow.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

This issue has been fixed in the BitNami RubyStack 2.0-2.

 
Avatar ganesh.k 2 post(s)

Thanks,It’s working fine for me now.

 
Avatar ctpatt 1 post

Sorry to raise an old topic, but I am having a similar issue with Imagemagick in Rubystack 2.1-0. I am trying to configure Imagemagick with the Paperclip plugin in Rails. It kept giving me errors, so I decided to try the command line and I think that’s the source of the problem. One time before I ran “identify -list format” and it gave me a whole list of formats then I tried identify in command line and it was successful. I didn’t change anything except the fact that I restarted but now I get “no decode delegate” and my format list is empty. The PATH variable for imagemagick is correct: C:\Rubystack\imagemagick and it is actually calling identify both in Rails and via command line.

 
Avatar danoo Administrator 81 post(s)

I have installed the latest version of RubyStack on Windows 7 and after several restarts everything is ok. Do you execute ‘identify -list format’ from the RubyStack console (started via ‘Use BitNami RubyStack’ shortcut) ?