This forum is no longer active. Please post your questions to our new community site

Unknown error when installing Ruby Stack

Subscribe to Unknown error when installing Ruby Stack 8 post(s), 2 voice(s)

 
Avatar ethos 9 post(s)

I tried to install Ruby Stack on Ubuntu and I got the following error after 100% of the installation was reached:
########################################
Error: Unknown error while running
/opt/rubystack-2.0-3/mysql/scripts/myscript.sh /opt/rubystack-2.0-3/mysql

 
Avatar ethos 9 post(s)

After fixing mysql/scripts/myscript.sh (one of the lines had relative path) I’m still getting this:

root@projects:/opt/rubystack# ./ctlscript.sh restart
Syntax OK
/opt/rubystack/apache2/scripts/ctl.sh : apache not running
/opt/rubystack/memcached/scripts/ctl.sh : Memcached stopped
/opt/rubystack/memcached/scripts/ctl.sh : Memcached started
/opt/rubystack/mysql/scripts/ctl.sh : mysql not running
100504 05:00:47 mysqld_safe Logging to ‘/opt/rubystack/mysql/data/mysqld.log’.
chown: invalid user: `mysql’

Why ‘mysql’ user is not found?

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Have you installed the stack as root user? Try to create the mysql user if it does not already exist:

/usr/sbin/useradd mysql

 
Avatar ethos 9 post(s)

I was able to finish the installation by editing and re-running /opt/rubystack/mysql/scripts/myscript.sh:
Just add line “cd /opt/rubystack/mysql” before and after mysql_install_db command in that file, it looks like the current directory is not properly preserved.

 
Avatar ethos 9 post(s)

Actually RubyStack is non functional as I can’t install any modules on top of it. How can I verify the installation?

To beltran: yes, I’m the root user.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

It is possible that the properties.ini file has not been created because of the error during the installation. Is it possible that you have SELinux enabled? Could y ou disable it before running the Stack installer?

 
Avatar ethos 9 post(s)

I traced it to the low memory issue. All works fine after I added memory and reinstalled.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

I’m glad to hear this!